Ask Your Question
3

Problem compiling the driver for Atheros Ar8161

asked 2013-02-09 12:54:27 -0500

zapman gravatar image

updated 2013-08-23 20:47:47 -0500

FranciscoD_ gravatar image

I just installed Fedora 18 (LXDE spin) but the network card which is an Atheros Ar8161 isn't recognized.

I read this thread and tried to follow the explanation, so I downloaded the alx driver from the Linux Foundation's website and extracted it. The problem occurs when I try to compile it. ./scripts/driver-select alx seems to work fine but make returns the following error:

make: *** /lib/modules/3.6.10-4.fc18.x86_64/build: No such file or
directory.  Stop.
make: *** [modules] Error 2

[zigzag@localhost compat-wireless-3.6.8-1-snpc]$ ./scripts/driver-select alx
Processing new driver-select request...
Backing up makefile: Makefile.bk
Backup exists: Makefile.bk
Backing up makefile: drivers/net/ethernet/broadcom/Makefile.bk
Backing up makefile: drivers/net/ethernet/atheros/Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: drivers/net/ethernet/broadcom/Makefile.bk
[zigzag@localhost compat-wireless-3.6.8-1-snpc]$ make
./scripts/gen-compat-autoconf.sh
/home/zigzag/compat-wireless-3.6.8-1-snpc/.config
/home/zigzag/compat-wireless-3.6.8-1-snpc/config.mk >
include/linux/compat_autoconf.h
make -C /lib/modules/3.6.10-4.fc18.x86_64/build
M=/home/zigzag/compat-wireless-3.6.8-1-snpc modules
make: *** /lib/modules/3.6.10-4.fc18.x86_64/build: No such file or
directory.  Stop.
make: *** [modules] Error 2

What am I doing wrong? Thanks in advance.

edit retag flag offensive close merge delete

Comments

I have the exact same problem as zapman, and I successfully did the suggested sudo yum install listed in hhlp's answer, but I still can't get the Make command to work. It's very frustrating, I guess I'm stuck with slow wireless for now.

WXguy gravatar imageWXguy ( 2013-03-18 16:59:48 -0500 )edit

actually i too got the same error but i didnt understood the solution to it please can some one elaborate it

kegatag gravatar imagekegatag ( 2013-08-23 14:44:46 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-09 14:41:09 -0500

hhlp gravatar image

have you prepared your system for compiling?, you need to install this :

sudo yum install gcc gcc-c++ make kernel-headers kernel-devel dkms
edit flag offensive delete link more

Comments

You can try downloading packages by connecting via wifi or usb dongle.

anurag gravatar imageanurag ( 2013-04-04 08:57:56 -0500 )edit

I am in exactly the same predicament. And further, having secured the loan of a wireless network adapter, I have also successfully '...prepared (my) system for compiling...' by installing the relevant gcc packages. Despite this, I am still getting exactly the same error message at the point of 'make'.

Would appreciate any help to get through this. Thanks in anticipation.

Leon gravatar imageLeon ( 2013-07-07 08:58:28 -0500 )edit
0

answered 2013-07-06 07:18:18 -0500

zapman gravatar image

Okay, I finally managed to compile the network card driver. It was enough to install from the Fedora DVD (and to check the appropriate boxes to install development tools). After unpacking the tarball and cd'ing into its directory, ./scripts/driver-select alx && make && make install && make unload && modprobe alx worked fine.

Now I can struggle with the bootloader :/

edit flag offensive delete link more
0

answered 2014-02-28 16:12:29 -0500

OFD1141 gravatar image

After struggling for weeks to get the Qualcomm/Atheros 8161 Gigabit ethernet controller to be recognized by RHEL 6.5, CentOS 6.5 or Scientific Linux 6.5, and submitting questions to various sites and opening a ticket with Red Hat, as I have a developer's license with them, I finally gave up. After multiple attempts at drivers and compiling, and I lost count of reboots and sneakernet attempts with USB sticks, I have moved it to Fedora 20 accordingly and bingo, it picked up the net immediately and is now running yum update.

I will say the guys at Red Hat and elrepo were very helpful and went the extra mile with me but there just isn't a working driver for the aforementioned distros yet for that controller.

So for those of you using Fedora you may want to consider upgrading to 20, depending on your hardware configs.

edit flag offensive delete link more

Comments

I have the same Qualcomm/Atheros AR8161 and tried to install both Fedora 21 and 22, but nothing works, I tried to run update, updated to the latest Linux Kernel 4.0.0.1 and still nothing! It sounds strange, that in Fedora 20 this works out-of-box, but in Fedora 22 it doesn't.

Mike B. gravatar imageMike B. ( 2015-04-26 01:22:12 -0500 )edit

Hey Mike, if you're still using Fedora at this point, what kernel are you using?

newk0001 gravatar imagenewk0001 ( 2015-10-17 23:02:26 -0500 )edit
0

answered 2013-09-20 05:46:56 -0500

Taras gravatar image

I have the same error when I run make. I have already installed recommended packages: sudo yum install gcc gcc-c++ make kernel-headers kernel-devel dkms

Fedora 19 x86_64. What I should install to get build directory?

edit flag offensive delete link more
0

answered 2013-11-12 02:30:38 -0500

nehaljwani gravatar image

updated 2013-11-12 02:35:12 -0500

For a fresh install of Fedora 19: Step 1: From a computer having access to internet, download the following packages from http://pkgs.org

cpp-4.8.1-1.fc19.x86_64.rpm
gcc-4.8.1-1.fc19.x86_64.rpm
gcc-c++-4.8.1-1.fc19.x86_64.rpm
glibc-2.17-14.fc19.x86_64.rpm
glibc-common-2.17-14.fc19.x86_64.rpm
glibc-devel-2.17-14.fc19.x86_64.rpm
glibc-headers-2.17-14.fc19.x86_64.rpm
kernel-devel-3.9.5-301.fc19.x86_64.rpm
kernel-headers-3.9.5-301.fc19.x86_64.rpm
libmpc-1.0.1-1.fc19.x86_64.rpm
libstdc++-devel-4.8.1-1.fc19.x86_64.rpm
perl-5.16.3-264.fc19.x86_64.rpm
perl-Carp-1.26-243.fc19.noarch.rpm
perl-Encode-2.51-1.fc19.x86_64.rpm
perl-Filter-1.49-1.fc19.x86_64.rpm
perl-libs-5.16.3-264.fc19.x86_64.rpm
perl-macros-5.16.3-264.fc19.x86_64.rpm
perl-PathTools-3.40-1.fc19.x86_64.rpm
perl-Pod-Escapes-1.04-264.fc19.noarch.rpm
perl-Pod-Simple-3.20-264.fc19.noarch.rpm
perl-Scalar-List-Utils-1.27-246.fc19.x86_64.rpm
perl-Socket-2.009-2.fc19.x86_64.rpm
perl-threads-1.87-1.fc19.x86_64.rpm
perl-threads-shared-1.43-2.fc19.x86_64.rpm

Step 2: Copy them to the machine and run the command:

# yum install *.rpm

Step 3: Download https://www.kernel.org/pub/linux/kernel/projects/backports/2013/03/04/compat-drivers-2013-03-04-u.tar.bz2 (compat-drivers-2013-03-04-u.tar.bz2) then run the commands:

# tar -xf compat-drivers-2013-03-04-u.tar.bz2
# cd compat-drivers-2013-03-04-u
# ./scripts/driver-select alx && make && make install
# reboot

Taken From: http://commandlinewani.blogspot.in/2013/11/how-to-install-atheros-wired-lan.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2013-02-09 12:54:27 -0500

Seen: 6,017 times

Last updated: Feb 28 '14