Ask Your Question
2

Transaction check error during google earth install

asked 2016-04-08 05:35:39 -0500

thingummybob gravatar image

Please understand that I HAVE tried several searches, blogs etc. but want to ask here for specific reasons which are:

I've previously managed to foul up or entirely break my Fedora installation by following "solutions" posted elsewhere to problems encountered when installing google earth and which have sometimes involved editing files and permissions which, as a relative newbie to Linux, I've not understood but simply blindly followed. The results have not been good ;0)

I now have (yet another) new install of Fedora 23, fully up to date. Having previously had problems installing the Linux port of Google Earth, I decided to begin by downloading and saving the rpm rather than allow the default "software installer" to manage the process.

Once downloaded, I proceeded to install using "$ sudo dnf install <path to="" download.rpm="">"

The first thing that appeared is a long list of dependencices, which are now downloaded and held in a cache while I resolve the next step, which is the problem itself.

I have this message in the terminal:

Error: Transaction check error: file /usr/bin from install of google-earth-stable-7.1.4.1529-0.x86_64 conflicts with file from package filesystem-3.2-35.fc23.x86_64

Error Summary

I am a newbie but I suspect I don't want to simply start fiddling with what looks like a default/core Fedora package simply to allow the install to proceed (assuming it would). Could someone please provide some sort of overview of what the problem might be, and which tools/commands I should be using to trace and resolve the file conflicts?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-10 02:11:57 -0500

thingummybob gravatar image

updated 2016-12-02 02:39:15 -0500

Edited my answer simply to reflect the fact that once upgraded to Fedora 25, I have no trouble installing Google Earth. Nicely done folks! ;0)

edit flag offensive delete link more

Comments

You can check if this still works: https://ask.fedoraproject.org/en/ques...

(replace yum with dnf if you execute any of these commands that contain yum).

florian gravatar imageflorian ( 2016-04-11 10:34:50 -0500 )edit
florian gravatar imageflorian ( 2016-04-11 10:38:18 -0500 )edit

thanks, but umm... this still seems to involve workarounds. Like other posters on the forum you linked to, I'm not happy about messing with file perms or risking breaking my installation (yet again!) when in fact it would appear that either the app itself needs fixing, or Fedora doesn't really support it. Utterly pointless offering a download that essentially doesn't work, but thanks for your input/suggestions :0)

thingummybob gravatar imagethingummybob ( 2016-04-18 13:57:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-08 05:35:39 -0500

Seen: 538 times

Last updated: Dec 02 '16