Ask Your Question
0

How do I disable middle button on an Apple Magic Mouse?

asked 2016-04-15 20:36:24 -0500

cmurf gravatar image

Macbook + Magic Mouse, and this mouse has no actual buttons. It senses where my finger is at the time I click, and that's how it registers left vs right click on Windows and OS X, but on Fedora I get a middle button also and it's just too close to left button. So when I click what I think is left button, it makes Firefox tab vanish, and often pastes things from the clipboard into random locations. It's really frustrating. Is there a way to disable this?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-04-15 20:39:01 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Yes I'm going to answer my own question.

xinput 
xinput --set-button-map 13 1 0

The first xinput lists devices, and the mouse on my system has id=13. That's where the 13 in the set-button-map command comes from. I don't actually understand why 1 works, I'd think it's 2, for 2nd button, but that doesn't work. But 1 is the "button" designation and 0 is the value, i.e. disable. Anyway, it works and now there's no middle button.

Credit goes to: http://lists.fedoraproject.org/archiv...

edit flag offensive delete link more

Comments

So this turns out to be suboptimal. There's now a region in the middle of the mouse that doesn't respond to any click. What's needed is a way to make it act like a two button mouse.

cmurf gravatar imagecmurf ( 2016-04-17 12:30:35 -0500 )edit
0

answered 2017-03-29 14:49:19 -0500

davdux gravatar image

Hi !

I try your solution but...cd

[root@linux ~]# xinput
Unable to connect to X server

Because I am under Fedora 25, I don't have any X server, I presume... How to make it possible ?

Thank you !

edit flag offensive delete link more
0

answered 2017-03-29 14:56:46 -0500

davdux gravatar image

Hi !

I try your solution but...cd

[root@linux ~]# xinput
Unable to connect to X server

Because I am under Fedora 25, I don't have any X server, I presume... How to make it possible ?

Thank you !

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-15 20:36:24 -0500

Seen: 432 times

Last updated: Apr 15 '16