Ask Your Question
1

Can't access Win homegroup

asked 2016-06-04 09:29:46 -0500

deadstick gravatar image

updated 2016-06-10 10:55:51 -0500

hhlp gravatar image

Machine setup: 3 Windows machines in a homegroup, one Fedora desktop, Netgear R7000 router.

The Fedora machine had a mobo failure and I replaced the mobo. Existing Linux installation had problems with the mobo change, so I did a new install of fedora23. Now it can access the Internet, but not the homegroup.

Homegroup machines can ping the machine by IP, but not by name. PuTTY from a homegroup machine gets "host does not exist" when attempted by name; when attempted by IP, it briefly brings up a terminal, then gets "Connection refused".

Router shows the Fedora machine attached with static DHCP.

ifconfig output:

[root@abelard sleep.d]# ifconfig
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.13  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::428d:5cff:fee2:9b6d  prefixlen 64  scopeid 0x20<link>
        ether 40:8d:5c:e2:9b:6d  txqueuelen 1000  (Ethernet)
        RX packets 21475  bytes 9030055 (8.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6213  bytes 826256 (806.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 5  bytes 389 (389.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5  bytes 389 (389.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.124.1  netmask 255.255.255.0  broadcast 192.168.124.255
        ether 52:54:00:e0:e8:f6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Suggestions? Thanks...rj

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2016-06-04 16:10:50 -0500

swathe gravatar image

Is fedora picking up DNS from the router and is it using the router as a DNS server or Internet based DNS servers such as Googles or your ISPs?

Perhaps try using the routers IP address for one of your DNS servers.

edit flag offensive delete link more

Comments

Yes, I am using the router as a DNS server. On any fedora reboot, the router assigns my designated static IP to the Linux box properly, and it appears properly in the router's "Attached Devices" table. Likewise, ifconfig shows the correct IP.

Summarizing from above:

Fedora box can ping other hosts on the network by IP, but not by name. Other hosts can ping Fedora by IP, but not by name. Fedora box has normal Internet access.

deadstick gravatar imagedeadstick ( 2016-06-05 15:02:22 -0500 )edit
0

answered 2016-06-08 09:41:10 -0500

sergiomb gravatar image

updated 2016-06-16 12:40:25 -0500

Latest updates of samba , have security fixes , that breaks some windows sharing. Please see if https://bugzilla.redhat.com/show_bug.... is related Thanks

I built samba 4.4.4 for F23 in copr https://copr.fedorainfracloud.org/cop...

and it works better .

edit flag offensive delete link more

Comments

From your link:

Steps to Reproduce: 1. Start smb4k and click on a workgroup name to scan the network. 2. The workgroup name disappears and no network share is shown, although there are many on the LAN.

Yes, that is precisely what happens. The suggestion "open service samba 139/tcp" gives no result.

deadstick gravatar imagedeadstick ( 2016-06-08 14:22:41 -0500 )edit

OK, this is happening on Samba 4.3.9 and I see that 4.4.4 was released on the 7th. How long does it take for a release to get into the repo's?

deadstick gravatar imagedeadstick ( 2016-06-09 11:01:55 -0500 )edit

and with samba 4.4.4 works ?

sergiomb gravatar imagesergiomb ( 2016-06-09 13:23:33 -0500 )edit
0

answered 2016-06-10 08:08:21 -0500

deadstick gravatar image

OK, finally cleared the problem when I transferred the runtime firewalld settings to permanent. Pls consider this one answered. Now I'll enter a display question in a new thread.

edit flag offensive delete link more
0

answered 2016-06-06 12:04:02 -0500

mpduty gravatar image

Just check this. You need to enable samba.

edit flag offensive delete link more

Comments

OK, I have Samba running and options set in firewalld, password protected sharing turned off in Windows, but no change. Also, temporarily stopping firewalld had no effect.

deadstick gravatar imagedeadstick ( 2016-06-06 15:26:57 -0500 )edit

OK, solved the ping problem by fixing a corrupted hosts file, but still can't see the fedora box from Win. Also can't PuTTY into it: always get "connection refused" (ssh and telnet are enabled in firewalld).

deadstick gravatar imagedeadstick ( 2016-06-07 09:36:27 -0500 )edit

Just realized smb4k is a KDE feature and I'm running Gnome - dunno how it got there. Now following the advice on the samba.org site, I get this:

" Run the command smbclient //BIGSERVER/TMP. " This yields the name of the one share set up. Next step: " On the PC, type the command net view \BIGSERVER. " This gets no response: the prompt doesn't return until I enter Ctl-C. "Add BIGSERVER to your lmhosts file on the PC" Created an lmhosts file and added the server: no result.

deadstick gravatar imagedeadstick ( 2016-06-09 11:47:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-04 09:29:46 -0500

Seen: 619 times

Last updated: Jun 16 '16