Ask Your Question
0

By keyboard layout Neo 2 the Mod4 doesn't work

asked 2016-06-07 10:59:11 -0500

bigaru gravatar image

Intro The ordinary QWERTZ keyboard layout is limited, so I like to switch Neo 2 (like Dvorak) layout. I though it shouldn't be a big thing because Fedora supports Neo2/Dvorak/... out of the box. The common layout has 3 layers and Neo 2 has 6 layers.

Trouble According to the official Neo2 website, I have to press "> < \" key (left side) or "Alt Gr" key to enable layer 4. As I tried, the Modifier key Mod4 doesn't work. The others work.

Confusing When I let fedora show my keyboard layout, on the Mod4 key is written 'Level5 shift'. But if use this key, then I don't get character from Layer 5. I get characters, if the key is not pressed.

Is there a way to fix it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-09 09:10:16 -0500

bigaru gravatar image

I had a talk with Neo community. The reason might be that fedora delivers old version of neo. To fix it, they gave the following instructions:

    # cd /usr/share/X11
    # cp -r xkb xkb-original
  • Overwrite the existing files (Do not replace the whole xkb folder, unless you like to reboot fedora normal)
    # tar -xvzf xkb.tgz
  • reboot & enjoy

Before you switch to Neo 2 layout, please turn Caps Lock & Number Lock off. Otherwise it won't work properly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-07 10:59:11 -0500

Seen: 237 times

Last updated: Jun 07 '16