Ask Your Question
1

how to remove wrong repository

asked 2016-06-20 20:51:23 -0600

noammo gravatar image

updated 2016-06-21 04:22:54 -0600

hhlp gravatar image

hi, I just moved from Ubuntu to Fedora, and I tried to install driver, and out of a habit, I did this

sudo dnf --add-repo ppa:hanipouspilot/rtlwifi

and yes, it's Ubuntu way, not Fedora.. anyway.. now, everytime that I'm using dnf, I get this message

[noam@localhost-localdomain ~]$ sudo dnf update
> 
Repository 'hanipouspilot_rtlwifi': Error parsing config: Error parsing "baseurl = ppa:hanipouspilot/rtlwifi": URL must be http, ftp, file or https not "ppa"
> 
Last metadata expiration check: 0:20:29 ago on Tue Jun 21 03:30:15 2016.
Dependencies resolved.
> 
Nothing to do.
> 
Complete!

(same with install, remove, and autoremove, etc..)

is someone know how to fix that? I'm tried for a long time without any succes.. I will be glad for any help :)

Thanks, Noam

edit retag flag offensive close merge delete

Comments

1

Check out /etc/yum.repos.d/. Very helpful to get to know the files and their content in this directory...

florian gravatar imageflorian ( 2016-06-20 22:32:32 -0600 )edit

yes, it's fixed the problem just great :) I'll remember that directory for next time, it's seem like a useful directory P:

noammo gravatar imagenoammo ( 2016-06-20 23:18:30 -0600 )edit

3 Answers

Sort by ¬Ľ oldest newest most voted
2

answered 2016-06-20 21:21:14 -0600

skytux gravatar image

updated 2016-06-20 22:51:50 -0600

$ sudo rm /etc/yum.repos.d/hanipouspilot_rtlwifi.repo

Are you sure you added that repo using dnf --add-repo? Because the proper way should be dnf config-manager --add-repo.

HTH.

edit flag offensive delete link more

Comments

1

oh.. yes I'm added with config-manager, just forgot to write it here.. my mistake..

anyway - it's works! Thanks!!

noammo gravatar imagenoammo ( 2016-06-20 21:30:37 -0600 )edit
2

answered 2016-06-20 21:31:45 -0600

sideburns gravatar image

Welcome to ask.fedora. The Fedora Documentation says that you can disable a repo by running this command as root:

dnf config-manager --set-disabled repository…

The repo data will still be there, but it won't get used again unless you specifically enable it, either permanently or for that specific dnf action.

edit flag offensive delete link more

Comments

thanks, and yes, i tried this, but it write that this is not a valid repo. (...URL must be http, ftp, file or https not "ppa"... anyway.. /etc/yum.repos.d/ was very useful in this situation :)

noammo gravatar imagenoammo ( 2016-06-20 23:11:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-20 20:51:23 -0600

Seen: 2,424 times

Last updated: Jun 21 '16