Ask Your Question
2

Bumblebee not working

asked 2016-06-29 18:09:32 -0500

mseleng gravatar image

updated 2016-07-04 05:05:20 -0500

Hi, I have installed Bumblebee, following the instructions on the official page.

Then I wanted to check whether it is correctly installed and running, i ran optirun glxgears -info | grep GL_VENDOR and I got the following output

[ 1862.301805] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1862.301871] [ERROR]Could not connect to bumblebee daemon - is it running?

When I tried to run the bumblebee daemon manually, using bumblebeed, I got:

modprobe: FATAL: Module bbswitch not found in directory /lib/modules/4.5.2-302.fc24.x86_64
[ 1934.657769] [ERROR]Module bbswitch could not be loaded (timeout?)
[ 1934.657797] [WARN]No switching method available. The dedicated card will always be on.
[ 1934.659638] [ERROR]Module 'nvidia' is not found

That looks weird, cuz I am pretty sure I got bbswitch installed and also got the nvidia GPU. To move forward I ran bumblebee-nvidia --debug which gave me the following output:

ERROR: Unable to find the kernel source tree for the currently running kernel. 
   Please make sure you have installed the kernel source files for your
   kernel and that they are properly configured; on Red Hat Linux systems,
   for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
   installed.  If you know the correct kernel source files are installed,
   you may specify the kernel source path with the '--kernel-source-path'
   command line option.

Then it suggests to look into /var/log/nvidia-installer.log, but there is only this information also.

I reviewed the versions of instaled bumblebee packages and I found out that they were for kernel 4.5.7-300, but running uname -r says, that I am only running kernel 4.5.2.302. However, dnf update does not update kernel (maybe it did, later and I didn't realize?) and also grub is saying that only 4.5.2-302 kernel is installed, alongside with Win10.

Could you guys help? I was googling a lot recently, but I didn't find anything useful.

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-12 14:06:10 -0500

mseleng gravatar image

So this got fixed by the latest kernel update and bumblebee's update to the newest version following.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-06-29 18:09:32 -0500

Seen: 750 times

Last updated: Jul 12 '16