Ask Your Question
4

Tap to click missing from Fedora 24

asked 2016-07-02 12:53:12 -0500

maweki gravatar image

I just updated my ASUS X53E from Fedora 23 to 24 and tap-to-click stopped working. Also, in the gnome-settings there is no way to set up my touchpad, while the media-keys to enable/disable the touchpad still work fine.

edit retag flag offensive close merge delete

Comments

I have the same problem, on Fedora 24 x86_64, Asus K46CA...

Ferm gravatar imageFerm ( 2016-07-02 23:54:14 -0500 )edit

Me too! I have the same problem. Fedora 24 x86_64, Asus X555LF. I can't enable tap to click, and natural scrolling. Also gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true not work for me

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-07-03 10:17:51 -0500 )edit

I have the same problem with Asus TP300L (Fedora 24 x86_64)

kifcaliph gravatar imagekifcaliph ( 2016-08-02 01:58:41 -0500 )edit

i have the same problem with Dell 3537(Fedora 24)

sajja gravatar imagesajja ( 2016-10-09 11:13:31 -0500 )edit

6 Answers

Sort by ยป oldest newest most voted
2

answered 2016-07-03 08:59:42 -0500

Constantine gravatar image

Run this from a console, without sudo:

gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true

edit flag offensive delete link more

Comments

not work it aniway, I did that before comment in this question.

Ferm gravatar imageFerm ( 2016-07-03 12:45:01 -0500 )edit
2

answered 2016-07-18 01:20:17 -0500

whot gravatar image

GNOME requires the libinput driver to be running, otherwise those gsettings won't have any effect. I suspect you have an xorg.conf snippet that overrides the default config and assigns the synaptics driver instead. A simple xinput list-props "device name" should show you, the properties are prefixed with the driver name.

That's why installing the libinput driver fixed it for mkovarik. xorg-x11-drv-libinput comes with the X config to assign itself to the touchpads and (s)he didn't have an override. You appear to have one, removing it will make it work.

edit flag offensive delete link more

Comments

thanks, I will try do that

Ferm gravatar imageFerm ( 2016-07-18 08:33:43 -0500 )edit
2

answered 2016-07-09 17:34:15 -0500

benitezCarvalho gravatar image

I solved this problem by reading this: https://wiki.archlinux.org/index.php/... I hope it helps you too.

edit flag offensive delete link more

Comments

yeahp... its work...

Ferm gravatar imageFerm ( 2016-07-10 13:06:16 -0500 )edit
1

thanks. works... synclient TapButton1=1

jrussey gravatar imagejrussey ( 2016-07-20 06:51:09 -0500 )edit

+1 benitezcarvalho

thanks for your help: The_touchpad_is_not_working

bfurtado gravatar imagebfurtado ( 2016-09-08 10:17:52 -0500 )edit

Thank you, although copy pasting working solution directly in the anwser could help :)

Alexandre Bourlier gravatar imageAlexandre Bourlier ( 2016-12-11 05:56:31 -0500 )edit
2

answered 2016-07-05 19:33:13 -0500

MaLDiTo_TeXuGo gravatar image

I can enable tap-to-click on gnome classic but not on wayland, inspite of once enabled, works on wayland too.

edit flag offensive delete link more
1

answered 2016-07-04 10:14:46 -0500

mkovarik gravatar image

Installation of xorg-x11-drv-libinput fixed issue for me

edit flag offensive delete link more

Comments

Thanks, but it's installed...

Ferm gravatar imageFerm ( 2016-07-04 13:33:40 -0500 )edit
0

answered 2016-07-22 16:35:16 -0500

Ferm gravatar image

I revomed the package xorg-x11-drv-synaptics and file configuration of xorg driver

sudo dnf remove xorg-x11-drv-synaptics

sudo rm /etc/X11/xorg.conf.d/taptouch.conf

After install the package xorg-x11-drv-libinput its works...

sudo dnf install xorg-x11-drv-libinput

image description

edit flag offensive delete link more

Comments

This solved it for me. I got here by installing and then removing plasma-desktop. This disabled libinput. I had to follow these steps to re-enable libinput.

panina gravatar imagepanina ( 2016-09-05 04:38:15 -0500 )edit

Didn't work for me

Alexandre Bourlier gravatar imageAlexandre Bourlier ( 2016-12-11 05:57:04 -0500 )edit

Still valid in fedora 25. It worked for me.

Rubyo gravatar imageRubyo ( 2017-02-14 06:45:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-02 12:53:12 -0500

Seen: 7,059 times

Last updated: Jul 22 '16