Ask Your Question
0

Problem installation nodejs and npm on fedora24

asked 2016-07-06 08:55:50 -0500

mos gravatar image

Following the angularjs quickstart instruction on https://angular.io/docs/ts/latest/qui... I tried to install npm and nodejs checking correct versions. On default repository I can found lts version, but angularjs needs running at least node v5.x.x and npm 3.x.x. I tried to install npm enabling updates-testing repository but It return a strange error.

# dnf install npm nodejs --enablerepo=updates-testing
Last metadata expiration check: 0:14:17 ago on Wed Jul 6 15:00:15 2016.
Error: package npm-3.5.4-5.fc24.noarch requires nodejs(engine), but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

Please help me!

edit retag flag offensive close merge delete

Comments

1

If you are enabling update-testing then you are enabling a beta package therefore there maybe issues. dnf install npm nodejs should work. Or at least works for me.

aeperezt gravatar imageaeperezt ( 2016-07-06 09:31:21 -0500 )edit

I can install only nodejs without problem but for angularjs 2 needs major version of both package. npm is present on nodejs installation and the versions are: [root@mos-hp620 ~]# npm -v
2.15.5
[root@mos-hp620 ~]# node -v
v4.4.6
The problem is present also without update-testing. # dnf install npm
Last metadata expiration check: 0:13:18 ago on Thu Jul 7 09:39:18 2016.
Error: package npm-3.5.4-5.fc24.noarch requires nodejs(engine), but none of the providers can be installed
...

mos gravatar imagemos ( 2016-07-08 03:00:43 -0500 )edit

The issue is that nodejs v4.4.6 is providing an older npm (2.15).. thus preventing newer npm from being installed.

Urkle gravatar imageUrkle ( 2016-08-26 09:14:39 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-08-26 09:40:55 -0500

Urkle gravatar image

Bug report for this issue. https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more
0

answered 2016-07-07 01:30:52 -0500

D4zzY gravatar image

For v6.3

su

curl --silent --location https://rpm.nodesource.com/setup_6.x | bash -

sudo dnf -y install nodejs gcc-c++ make

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-06 08:55:50 -0500

Seen: 2,453 times

Last updated: Jul 07 '16