Ask Your Question
1

How to install Android Studio on Fedora 24

asked 2016-08-08 09:18:44 -0500

noammo gravatar image

updated 2016-08-08 10:17:09 -0500

I'm trying to install Android Studio on Fedora 24, but the jdk doing problems.. When I run studio.sh file (./studio.sh) it's print this error

[noam@localhost bin]$ 
[noam@localhost bin]$ ./studio.sh
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0

JDK Required: 'tools.jar' seems to be not in Studio classpath.
Please ensure JAVA_HOME points to JDK rather than JRE.
[noam@localhost bin]$

And this is what java -version print

[noam@localhost ~]$ 
[noam@localhost ~]$ java -
openjdk version "1.8.0_101"
OpenJDK Runtime Environment (build 1.8.0_101-b14)
OpenJDK 64-Bit Server VM (build 25.101-b14, mixed mode)
[noam@localhost ~]$

And i've already fixed that before, (I installed some packages, not remember which) and the installation has worked fine, but after the installation was done, so it wrote that it didn't find the jdk, so I have removed all the packages that I installed before (the packages that I installed to fix the tools.jar error message) to start from scratch.

So what do I need to do, to install Android Studio, and make it works in 100%? (without annoying jdk errors)

Thanks in advance.

UPDATE

I've run sudo update-alternatives --config java and choosee /usr/java/jdk1.8.0_101/jre/bin/java (which was before java-1.8.0-openjdk.x86_64 (/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-1.b14.fc24.x86_64/jre/bin/java))

[noam@localhost ~]$ 
[noam@localhost ~]$ sudo update-alternatives --config java

There are 2 programs which provide 'java'.

  Selection    Command
-----------------------------------------------
*  1           java-1.8.0-openjdk.x86_64 (/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.101-1.b14.fc24.x86_64/jre/bin/java)
 + 2           /usr/java/jdk1.8.0_101/jre/bin/java

Enter to keep the current selection[+], or type selection number: 
[noam@localhost ~]$

So now, the installation starts, but I get this error message

http://i.imgur.com/6dy9NjK.png

"Unable to run msdcard"

At the first time, it's have been appear after a couple of minutes, (after a couple of minutes when it write "downloading android-sdk..." something like that) and in the other times, when I start the installation, it's appears immediately - after a couple of seconds.. (maybe cache, idk)

Anyway - how can I fix that now? (that was my problem also in the last time when I tried to install android studio)

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2016-08-10 03:49:42 -0500

cadogan gravatar image

updated 2016-08-10 14:00:51 -0500

Hello,

You are missing some of the 32bit libraries. After quick search around I found that libstdc is missing (standarnt c++ library).

dnf install libstdc++-6.1.1-3.fc24.i686

Usefull way to find which packages provides this library: dnf provides libstdc++

edit flag offensive delete link more
0

answered 2016-09-06 19:49:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have the same problem. I did everything that tells on the web site but, still doesn't work. When i try to install the lib the terminal results this message "Os pacotes baixados foram salvos no cache até a próxima transação bem sucedida. Você pode remover os pacotes em cache executando 'dnf clean packages'. Error: Transaction check error: o arquivo /usr/share/doc/glibc/NEWS da instalação de glibc-2.23.1-10.fc24.i686 conflita com o arquivo do pacote glibc-2.23.1-7.fc24.x86_64

Error Summary"

edit flag offensive delete link more
0

answered 2016-08-29 19:30:47 -0500

srr gravatar image

Check out this site, it helped me on Fedora 24: android-studio-fedora

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-08-08 09:18:44 -0500

Seen: 3,150 times

Last updated: Aug 10 '16