Ask Your Question
0

Fedora24 Live X blackscreen (+cursor) then crash? GTX 1070

asked 2016-08-09 07:20:55 -0500

f24live5 gravatar image

updated 2016-08-09 16:09:23 -0500

Hi,

I was trying to test out Fedora 24 live (setup using dd with a USB stick) on a very new desktop machine with a Nvidia GTX 1070 video card, and I can't get to X. The usb works on my laptop without any noticeable error.

The boot process seems to proceed normally, and X seems to start -- a mouse cursor appears on a black screen which I can move around. Then, however, there's some weird graphical flashes near the bottom of the screen, and X closes and re-open a few times (with graphical glitches flashing), until finally giving up and crashing to the command line.

I switched over to a VT and ran dmesg | tail and the messages are all gnome-shell trap invalid opcode errors plus an error about setting MTRR. My searching for these two errors has produced nothing tangible.

I also did lspci -k and saw that the nouveau driver was in use.

I tried all three of the suggestions here other than trying to install using VNC, as well as trying nouveau.modeset=0 on the boot. These all produced the same results, and, to my surprise, nouveau was still listed for my video card using lspci -k even with inst.xdriver=vesa or nouveau.modeset=0 added to the boot line.

After this, I decided to try a Korora live image (based on Fedora, made in the same manner using dd), and it was able to boot to the desktop. Checking lspci -k, it seemed to be using nouveau as well, so it confused me a bit. However, afterwards, I realized I downloaded the MATE version of Korora, rather than the default GNOME, so I'm wondering if this is a GNOME problem, rather than (my initial assumption of being) a GTX 1070 support problem (I could test a Fedora spin of a different DE later today if someone thinks it would be helpful).

Any help or advice would be greatly appreciated.

Thanks

EDIT I tried the Fedora 24 XFCE live workstation spin, and I was able to successfully get to X (I wanted to try because I noticed Korora was MATE instead of GNOME, and the gnome-shell trap invalid opcode errors) -- so I'm not sure what to make of the problem. Is it a problem between GTX 1070 and GNOME specifically?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-09 14:15:33 -0500

baoboa gravatar image

updated 2016-08-09 14:18:32 -0500

to disable nouveau at boot time

nouveau.modeset=0 rd.driver.blacklist=nouveau

gtx 1070 is pascal family hardware, it's only supported by the kernel >= 4.8, you need to install the proprietary driver after ( text mode ) install. Usually a degraded graphic mode is proposed at boot time for the live cd, maybe it will work for you.

edit flag offensive delete link more

Comments

Unfortunately, this results in the same error. I added an edit to the original post, but I tried the Fedora 24 XFCE Live Workstation, and it successfully booted to X and I was able to interact with the system. It had (I believe) 4.5.5, and lspci -k showed nouveau for my video card. Would a text install be the only work around for GNOME, or is something else going on between GNOME and the GTX 1070?

f24live5 gravatar imagef24live5 ( 2016-08-09 16:11:27 -0500 )edit

gnome shell require 3D capabilities, you can solve the problem by installing the last proprietary driver after the disk install. http://rpmfusion.org/Howto/nVidia#New... or http://negativo17.org/nvidia-driver/

baoboa gravatar imagebaoboa ( 2016-08-10 11:55:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-09 07:20:55 -0500

Seen: 1,482 times

Last updated: Aug 09 '16