Ask Your Question
2

How to disable "large text" / font scaling accessibility feature in GDM

asked 2016-08-10 19:49:44 -0500

terrycloth gravatar image

updated 2016-10-31 16:42:43 -0500

background

I recently tried installing the SteamOS Session package, from a third-party repository. It adds Steam as an available desktop login session, to run in place of your regular desktop, theoretically saving some resources for your game. When the SteamOS Session initially downgraded its graphical settings to run on my computer, it also permanently changed settings for the entire system. I've already reported this bug, but haven't yet gotten any feedback from the packager.

To fix it, I had to go to GNOME Settings > Displays, and change the resolution back to the normal setting for my monitor, 1920×1080. The game also apparently enabled the "Large Text" feature in GNOME's accessibility settings. I was unable to turn this off using the Universal Access menu, though, either through the accessibility icon in the top bar or the GNOME Settings application; I was only able to turn it off by going to GNOME Tweak Tool > Fonts > Scaling Factor, and changing the value from 1.5 back to 1.0. I also tried forcing the SteamOS Session graphics settings up to match my monitor's native resolution.

the continuing problem

So everything is back to normal on my desktop --- except the GDM login screen still has Large Text enabled. Obviously, I've tried clicking on the Accessibility icon at the top of the login screen too and turning the Large Text switch to "off" but this doesn't do anything. The switch won't move to off. And turning off font scaling after I log in hasn't had any effect on GDM.

things I've tried to fix it

I've also tried launching GNOME Tweak Tool as root (i.e., call from the command line with sudo), to see if it would change settings for the root account or something, but font scaling was already at 1.0.

I also perused the files under /etc/gconf/, /etc/gdm/, and looked through all the settings in GConf-editor, but couldn't find anything related to "large text" or "font scaling" or anything like that. It's possible that I just missed it, but I dunno what exactly I should be looking for.

I also checked the values printed by gsettings list-recursively, both with and without sudo, and org.gnome.desktop.interface text-scaling-factor is already set to 1.0.

I'm running GNOME 3.20 on Fedora 24 (64-bit). My user account is the only non-system user. I'm not sure what else to do :/

Final update

The problem seems to have gone away on its own. Perhaps because of a package update? I think I may have gone a few days before I really noticed, so I'm not sure what happened to fix it. But one day I booted my computer and the GDM login screen displayed all text at its normal size.

So if anyone were to post another possible solution, I guess I couldn't really confirm whether it would be the correct answer or not :/

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-04 08:54:24 -0500

genodeftest gravatar image

Have you tried reinstalling gdm?

GDM stores its preferences in /var/lib/gdm. You could try these steps (be careful!):

  1. log in on any tty as root
  2. stop gdm through systemctl
  3. delete /var/lib/gdm/.local/share/dconf/user
  4. restart gdm or reboot (preferred)

If you broke something, reinstall gdm.

edit flag offensive delete link more

Comments

I didn't see any config files that seemed pertinent to the problem, but I tried temporarily moving each the directories under /var/lib/gdm/ anyway. I would move one directory elsewhere, reboot, and when that didn't fix the problem, restore that directory and try again with another. The font scaling accessibility setting does not seemed to be stored anywhere in .cache/.config/.local/.nv/ or .pulse/

.pulse I would guess is for PulseAudio, and .nv is for Nvidia, so it's not surprising that messing with those folders didn't help. I'm just shooting in the dark here.

terrycloth gravatar imageterrycloth ( 2016-10-04 18:20:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-10 19:49:44 -0500

Seen: 1,584 times

Last updated: Oct 31 '16