Ask Your Question
1

Fedora 16 login screen after network initialization

asked 2011-11-11 04:07:13 -0500

iNecas gravatar image

Hi,

I'm using virtual machines for testing purposes and I have a script /sbin/ifup-local on each new virtual machine to show the hostname on login screen (runlevel 3) (so that I can use ssh to login to the machine immediately:

 #!/bin/bash
 # sets up the login screen to show hostname address

TEMPLATE_FILE=/etc/issue.bak
MESSAGE_FILE=/etc/issue

if ! [[ -e $TEMPLATE_FILE ]]; then
  # running the first time - creates a template
  cp $MESSAGE_FILE $TEMPLATE_FILE
fi

if [[ -e $MESSAGE_FILE ]]; then
  rm $MESSAGE_FILE
fi

cp $TEMPLATE_FILE $MESSAGE_FILE
echo Hostname: `hostname` >> $MESSAGE_FILE

It works without problems in Fedora 15, but with Fedora 16 it seems the ifup-local script gets invoked after the login screen has showed up. I suspect that it's done this way so that the boot time looks faster (I know Windows does it this way).

So my question is can I force the system to wait for the network being configured before showing the login screen in runlevel 3?

edit retag flag offensive close merge delete

Comments

You can, probably by modifying the Unit files. Something like

After=network.service

will do it. The problem is, I haven't been able to figure out which file this needs to be added to :/

FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-15 07:51:49 -0500 )edit
systemctl --order | egrep "gdm|network"
FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-15 08:00:33 -0500 )edit
systemctl --order | egrep "gdm|network"
FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-15 08:00:34 -0500 )edit

Mine works as well :-)

lzap gravatar imagelzap ( 2011-11-18 04:40:06 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-11-17 04:08:35 -0500

lzap gravatar image

Not a systemd problem IMHO. Your network is probably NetworkManager configured, turn it off (in the /etc/sysconfig/network-scripts/ifcfg-eth0):

NM_CONTROLLED="no"

You have to turn it (ONBOOT and BOOTPROTO) on and make sure there is HWADDR, it wont work otherwise:

DEVICE="eth0"
HWADDR="XX:XX:XX:XX:XX:XX"
ONBOOT="yes"
BOOTPROTO="dhcp"

Please note once you save the file NetworkManager will kill your network, so you have to start it manually and also make sure network is configured to start.

chkconfig network on
service network start

Once you do that network will be started during the booting (and not after NM will show up). Good luck. -- lzap

edit flag offensive delete link more

Comments

I have to admin my solution is rough ;-)

lzap gravatar imagelzap ( 2011-11-21 06:28:07 -0500 )edit
0

answered 2011-11-17 00:21:55 -0500

mether gravatar image

Try asking in systemd devel mailing list or #systemd channel in Freenode

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-11 04:07:13 -0500

Seen: 748 times

Last updated: Nov 17 '11