Ask Your Question
0

GUI Application doesn't run with root access

asked 2016-09-09 10:24:17 -0500

AliZeynali gravatar image

updated 2016-09-09 10:27:34 -0500

Hi all

When I try to Run a GUI application as root ( like : sudo gparted ) I receive some thing like this :

No protocol specified

(gpartedbin:2710): Gtk-WARNING **: cannot open display: :0

I have one root user, that's all.

I searched a lot, There was too many question about it and no great answer to help, so I decided to ask it here hope for a good answer to help other people too.

and I kinda curios about the reason of this problem.

If you think there is not enough information just comment what you need to know.

and the last things I remember I done where simple updates and mess with gnome extensions.(maybe help)

Fedora 24

Thanks a lot

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-10 00:33:15 -0500

masteroman gravatar image

I have never experienced this issue, though, I always have regular user and then su -l/sudo into it and graphical apps work normally that way. Out of the reason, why don't you just use regular user and then sudo from it?

Have you tried this article from Arch wiki ? Specifically "Permanently allow root access" part.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-09 10:24:17 -0500

Seen: 437 times

Last updated: Sep 10 '16