Ask Your Question
0

Why do I need "nomodeset" in my dual-boot (F16, CentOS-6.2) grub?

asked 2012-01-13 02:42:36 -0500

anttyj gravatar image

updated 2014-09-28 13:41:20 -0500

mether gravatar image

I've got two Linux systems in my (old) Acer Aspire 3023 laptop. To begin with, they were CentOS-6.0 and Fedora 15. The CentOS system has separate /boot, /home and / (root) partitions, and the Fedora system is implemented with an LVM (logical volume manager). A few weeks ago I upgraded the Fedora system to Fedora 16. Everything still worked but when I updated the CentOS-6.1 to CentOS-6.2, the CentOS system would no longer boot properly. During the boot process, at some point the booting stops and a blank screen remains. At first this would look like a CentOS-6.2 problem but the boot loader in use is the grub2 of Fedora 16. To make a long story short, after some googling I appended the "nomodeset" command (right after 'rhgb quiet') to the /etc/grub.conf of CentOS-6.2 and ran '# grub2-mkconfig > /boot/grub2/grub.cfg' in Fedora 16 to make Fedora's grub2 take notice. Now the CentOS system boots OK even if CentOS-6 theme has changed to Fedora-10 type "growing white bar" at the bottom of the screen. Can anyone explain why the "nomodeset" command is needed in grub.cfg of Fedora 16? As an aside, why does grub2 assume the other OS is always 'msdos' if a computer is a dual-boot system? In my three dual-boot computers only one has Windows XP Pro as an alternative, all others are different Linux distros.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-01-13 10:07:04 -0500

lzap gravatar image

Too many question, let me try to answer your topic.

Setting "nomodeset" disables KMS. Kernel Mode Setting (KMS) provides faster mode switching for X and console. It also provides native-resolution VTs on some laptops and netbooks which, prior to this, would use some standard mode, e.g. 800×600 on a 1024×600 panel.

http://fedoraproject.org/wiki/HowtodebugXorgproblems

KMS can be problematic on some ATI and Intel cards. Since you have upgraded you have new drivers that can cause issues like that.

Grub is another story, it was also updated in Fedora 16 (I think to Grub 2 - that is a big change). Pay a visit this site if you still have issues/questions about how this new version works. It is sligtly different:

http://fedoraproject.org/wiki/Grub2

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-13 02:42:36 -0500

Seen: 9,839 times

Last updated: Jan 13 '12