Ask Your Question
0

I can't upgrade to Fedora 24!!!

asked 2016-10-20 08:36:59 -0500

etonar gravatar image

updated 2016-10-20 11:02:42 -0500

hhlp gravatar image

Hi, I got this error when I'm trying to upgrade to Fedora 24 from Fedora 23:

The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib/node_modules/npm/bin/npm conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/bin/npm-cli.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/bin/read-package-json.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/cli.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/doc conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/html conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/adduser.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/bin.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/bugs.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/build.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/add-local-tarball.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/add-local.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/add-named.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/add-remote-git.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/add-remote-tarball.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/cached-package-root.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib/cache/caching-client.js conflicts between attempted installs of npm-3.5.4-5.fc24.noarch and nodejs-1:4.6.0-5.fc24.x86_64
  file /usr/lib/node_modules/npm/lib ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-10-20 10:37:45 -0500

aeperezt gravatar image

Since all errors are con nodejs npm remove nodejs and npm packages upgrade and after that install then back.

edit flag offensive delete link more
1

answered 2016-10-20 13:44:01 -0500

ssieb gravatar image

The nodejs package in F24 has taken over the function of npm and obsoletes it, so I don't know why dnf is trying to install both.. You could try adding --best --allowerasing to the upgrade command line and see if that works better. Otherwise you will need to remove one or both of them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-10-20 08:36:59 -0500

Seen: 613 times

Last updated: Oct 20 '16