Ask Your Question
2

Fedora 24 won't boot after installing nvidia driver

asked 2016-11-04 08:21:05 -0500

Deepak_Suresh gravatar image

updated 2016-11-05 09:37:43 -0500

I'm running fedora on an intel i7 64 bit, which has nvidia optimus graphics card. I installed proprietary driver, LINUX X64 (AMD64/EM64T) DISPLAY DRIVER from nvidia's website. But, after this I'm stuck at a screen which says

[  OK  ] Started GNOME Display Manager.

I can access the tty console from here, before doing the installation from the text user interface I had blacklisted nouveau driver.

I referred this for installing nvidia, https://www.unixmen.com/install-nvidi... How do I get it to boot?

Thank you for your time.

Update: I tinkered a bit with it, more specifically, ran the following from tty

sudo dnf install lightdm lightdm-gtk
systemctl disable gdm.service
systemctl enable lightdm.service

hoping to get to desktop environment. Unfortunately, after doing the above, during booting, the fedora icon shows up , then a blinking cursor, that then gives way to a blank screen, not desktop or login screen. I can still access the tty consoles from there.

edit retag flag offensive close merge delete

Comments

I ran into the same problem and had to reinstall the whole system please accept an answer if it worked for you

TWTOoth gravatar imageTWTOoth ( 2016-11-05 00:41:50 -0500 )edit

Hi, Unfortunately, none of the answers till now worked. Did you encounterit after installing nvidia? I had bumblebee running, then decided to switch to nvidia, that's when things went awry for me.

Deepak_Suresh gravatar imageDeepak_Suresh ( 2016-11-05 09:39:58 -0500 )edit

when i installed nvidea every thing was fine untel i rebooted my laptom the same last message appeared as you wrote it and i couldn't access any visual display i could just activate a black screen terminal with root user prev. i tried to remove nvidia or undo things "i tried A LOT of ideas to" to restore my system but i decided to cut the chase and reinstall fedora24 all over again

i hope you wouldn't have to do that but let me know if you find a solution

TWTOoth gravatar imageTWTOoth ( 2016-11-06 01:56:32 -0500 )edit

I reinstalled it, nothing worked :-(

Deepak_Suresh gravatar imageDeepak_Suresh ( 2016-11-06 08:08:57 -0500 )edit

are you using fedora on some HP Envy15 Laptop ?? Cause mine has same configurations and I suffered same problems.

kumargaurav gravatar imagekumargaurav ( 2016-11-08 11:54:45 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-04 09:00:25 -0500

aeperezt gravatar image

If you got up to that you have boot, you need to press keys ctl+alt+f3 and you could login, you probably have 2 kernerl modules for video you need to disable one of them. Query install nvidia on Fedora on ask.fedoraproject.org and will find all information you need.

edit flag offensive delete link more
0

answered 2016-11-05 07:40:35 -0500

se-schwarz gravatar image

Try this guide to installing the nVidia driver. I did this yesterday, too. Works as expected. :-)

edit flag offensive delete link more
0

answered 2017-10-17 22:49:25 -0500

cadia gravatar image

I ran into the same error. I removed /etc/X11/xorg.conf and it seemed to get me back into the DE.

edit flag offensive delete link more
-1

answered 2016-11-04 13:33:13 -0500

Entropy813 gravatar image

Since you have an optimus laptop, you want to install bumblebee: https://fedoraproject.org/wiki/Bumblebee

The directions there are complete and easy to follow. Just note that you'll want to disable secure boot in your UEFI BIOS.

edit flag offensive delete link more

Comments

I had bumblebee running, even after that my system was unreasonably heating up, as if it was in the midst of an extremely expensive task. Yes, I followed the guide you mentioned to install bumblebee. The temperature was still 95+, I would shut my system down when it hit 100. So, I thought I'd give nvidia driver a chance. Now, all I get is a blank screen after booting, not desktop.

Deepak_Suresh gravatar imageDeepak_Suresh ( 2016-11-05 09:44:01 -0500 )edit

You can install bumblebee with the NVIDIA driver: $ sudo dnf install bumblebee-nvidia bbswitch-dkms primus kernel-devel This shouldn't cause your laptop to overheat as the discrete GPU should only be in use when you launch something using optirun or primusrun. If you have the NVIDIA driver installed without bumblebee your problem is likely that your system isn't loading the driver for your intel card. You can check your bios to see if you can disable the integrated GPU, but most will only have an option to disable the discrete.

Entropy813 gravatar imageEntropy813 ( 2016-11-07 12:01:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-04 08:21:05 -0500

Seen: 1,956 times

Last updated: Nov 05 '16