Ask Your Question
0

Fedora 24: Keyboard Media Controls stopped working after recent update

asked 2016-11-10 06:58:10 -0500

thingummybob gravatar image

updated 2016-11-10 16:08:49 -0500

I HAVE read the other posts on this issue but as yet my problem isn't resolved and/or other posts weren't relevant.

Everything's been working fine until this morning and my habitual dnf --refresh upgrade

After the upgrade my keyboard media keys did nothing at all. After a couple of reboots, and upgrading the Gnome Volume Mixer extension, function is now restored to the point where pressing the volume keys makes the on-screen icon appear, and the volume bar moves. The same behaviour is noted via the taskbar icons. My problem is that although the key press activates something, neither my music player of choice (the outstanding Quodlibet) nor, now, any media played in a browser - for example YouTube - can be controlled via the keyboard.

re @fcomida below: Installed and ran rpmconf and got the following output:

Configuration file '/etc/chrony.keys'
-rw-r-----. 1 root chrony 481 Jun  7 11:20 /etc/chrony.keys.rpmnew
-rw-r-----. 1 root chrony 111 Jun 23 09:54 /etc/chrony.keys

Configuration file '/etc/gdm/custom.conf'
-rw-r--r--. 1 root root 284 Jun 23 20:40 /etc/gdm/custom.conf
-rw-r--r--. 1 root root 226 Jun 28 18:56 /etc/gdm/custom.conf.rpmnew

Configuration file '/etc/cups/cups-browsed.conf'
-rw-r--r--. 1 root root  4090 Oct 29  2015 /etc/cups/cups-browsed.conf
-rw-r--r--. 1 root root 15566 Jun 10 06:17 /etc/cups/cups-browsed.conf.rpmnew

On checking those directories, no new files have been created yet i.e. there are no "/etc/.... rpm.new" files but only the original file. Should I perform this download/merge?

Just looked at history since yesterday (sorry about the length!)

Transaction ID : 102
Begin time     : Thu Nov 10 10:05:38 2016
Begin rpmdb    : 2066:b970f88012939ce6f20cc9f0f8e8d302b497c153
End time       :            10:06:56 2016 (78 seconds)
End rpmdb      : 2068:f9e842e941ba243656bf50a0646cb3956fd9ccde
User           : Alan <xxxx>
Return-Code    : Success
Command Line   : --refresh upgrade
Transaction performed with:
Installed     dnf-1.1.10-1.fc24.noarch        @@commandline
Installed     rpm-4.13.0-0.rc1.27.fc24.x86_64 @@commandline

Packages Altered:
Upgraded dracut-044-20.fc24.x86_64                          @@commandline
Upgrade         044-21.fc24.x86_64                          @updates
Upgraded dracut-config-rescue-044-20.fc24.x86_64            @@commandline
Upgrade                       044-21.fc24.x86_64            @updates
Upgraded dracut-live-044-20.fc24.x86_64                     @@commandline
Upgrade              044-21.fc24.x86_64                     @updates
Upgraded dracut-network-044-20.fc24.x86_64                  @@commandline
Upgrade                 044-21.fc24.x86_64                  @updates
Upgraded jasper-libs-1.900.1-34.fc24.i686                   @updates
Upgraded jasper-libs-1.900.1-34.fc24.x86_64                 @@commandline
Upgrade              1.900.13-1.fc24.i686                   @updates
Upgrade              1.900.13-1.fc24.x86_64                 @updates
Upgraded open-vm-tools-10.0.5-4.fc24.x86_64                 @@commandline
Upgrade                10.0.5-7.fc24.x86_64                 @updates
Upgraded open-vm-tools-desktop-10.0.5-4.fc24.x86_64         @@commandline
Upgrade                        10.0.5-7.fc24.x86_64         @updates
Upgraded perl-Errno-1.23-362.fc24.x86_64                    @@commandline
Upgrade             1.23-363.fc24.x86_64                    @updates
Upgraded perl-IO-1.35-362.fc24.x86_64                       @@commandline
Upgrade          1.35-363.fc24.x86_64                       @updates
Upgraded perl-Math-Complex-1.59-362.fc24.noarch             (unknown)
Upgrade                    1.59-363.fc24.noarch             @updates
Upgraded perl-Net-Ping-2.43-362.fc24.noarch                 (unknown)
Upgrade                2.43-363.fc24.noarch                 @updates
Upgraded perl-Pod-Html-1.22-362.fc24.noarch                 (unknown)
Upgrade                1.22-363.fc24.noarch                 @updates
Install  pigz-2.3.3-4.fc24.x86_64                           @fedora
Upgraded selinux-policy-3.13 ...
(more)
edit retag flag offensive close merge delete

Comments

1

It should nice to know which packages have been upgraded for having a clue of what happened. Also run rpmconf - a for any changed config file.

fcomida gravatar imagefcomida ( 2016-11-10 13:55:53 -0500 )edit
1

None of the upgraded packages seem related to your issue except maybe the kernel. Does everything works as expected booting the old kernel? Regarding the .rpmnew files (again no related to your issue), if you didn't modify any configuration you should accept maintainer's ones

fcomida gravatar imagefcomida ( 2016-11-10 20:04:37 -0500 )edit

Nice idea! Tried both previous kernels, sadly no improvement. Before I look at the keyboard itself: dconf editor shows that the media key settings are there. The keyboard is listed under xinput list I've no reason to think it's broken. Have tried other usb ports but still no joy.

Is this possibly a bios error? What else can I test or check before buying another keyboard - which of course I really need to work!

thingummybob gravatar imagethingummybob ( 2016-11-11 03:29:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-11 03:37:31 -0500

thingummybob gravatar image

Oh!

After about the tenth restart, I expanded the list of audio outputs shown on the Volume Mixer extension, and after selecting each one in turn and then going back to the desired one, it works!

I do not understand!? Obviously happy that it works again, but quite why this has happened will remain a mystery.

@fcomida - thanks for the help. If nothing else I've learned more about Fedora and my computer ;0)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-10 06:58:10 -0500

Seen: 144 times

Last updated: Nov 11 '16