Ask Your Question
1

Systemd disk errors, booting fails with certain kernels

asked 2016-11-12 21:10:03 -0500

Favorablestream gravatar image

updated 2016-11-22 13:38:55 -0500

Hello,

I seem to be having systemd disk errors when booting. I'll add a smartctl report but my laptop's SSD is only a few years old and more importantly this issue only happens with specific kernels so I believe the disk is fine.

I don't know how to retrieve logs for a boot that never completes so I'll attach camera pictures, sorry about that.

My disk is fully encrypted using Luks but these issues happen after my password is accepted.

From what I can see I get a bunch of IO errors and then systemd gets stuck running start jobs on my disks which never complete.

As I said one kernel is fine while my newer kernels have this problem so I don't believe the disk is failing.

4.8.8-300.fc25.x86_64 (doesn't work)

4.8.6-201.fc24.x86_64 (doesn't work)

4.8.4-200.fc24.x86_64 (doesn't work)

4.7.9-200.fc24.x86_64 (works)

I am running Systemd version 229.

Bootup messages: https://imgur.com/a/0LvvU

Smartctl data: http://pastebin.com/4TkE6uZ4

Fstab: http://pastebin.com/L9EAeseu

Disk partitions: http://pastebin.com/JRpdymtX

Disk UUIDs: http://pastebin.com/k66QV1Az

Crypttab: http://pastebin.com/n1zKaPwn

The main errors that I see when the start jobs are running are from journald failing to write entries because the file system is read only.

edit retag flag offensive close merge delete

Comments

I think your picture is missing the start of the problem. Try removing quiet and rhgb from the kernel command line in grub.

You could also try booting one of the live images from http://dl.fedoraproject.org/pub/alt/l... which should have a 4.8.x kernel now. That way you would be able to get better log info.

ssieb gravatar imagessieb ( 2016-11-16 13:33:52 -0500 )edit

I actually just ran a Fedora 25 upgrade so I'm running 4.8.8. 4.7.9 is still the only kernel that will boot for me though.

I removed rhgb and quiet and I have some pictures of the error messages before the never finishing start jobs begin.

Here's the album, hopefully it helps: https://imgur.com/a/hKHUE

I'll try a live image and see if it runs differently

Favorablestream gravatar imageFavorablestream ( 2016-11-21 18:37:18 -0500 )edit

Turns out I'm an idiot and forgot to actually generate the new grub.cfg. With rhgb and quiet actually off the text is a little too fast to follow. The point where I get stuck though prints the same text over and over and seems to be about ACPI errors.

I managed to get a picture but the text moves too quickly to read so it's not the clearest: http://imgur.com/a/C671V

Favorablestream gravatar imageFavorablestream ( 2016-11-21 20:00:20 -0500 )edit

I would recommend filing a bug report for this. One thing you could try is adding acpi=off to the kernel command line. You don't need to modify the grub config. Just edit the boot entry from the grub menu.

ssieb gravatar imagessieb ( 2016-11-22 02:25:11 -0500 )edit

I'll give that a try and file a bug with Systemd.

Thanks for the help

Favorablestream gravatar imageFavorablestream ( 2016-11-22 13:20:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-09 09:52:27 -0500

I'm having the same problem. The only difference is that only my /home partition is encrypted. Have you already filed a bug @Favorablestream?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-12 21:01:23 -0500

Seen: 173 times

Last updated: Nov 22 '16