Ask Your Question
0

MySql not starting up.

asked 2016-11-14 01:12:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have fedora 24 cinnamon on my laptop. I have installed mySql on this machine. but when I try to run mySql, it says:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

and when I try this: service mysqld status I get this as the result:

Redirecting to /bin/systemctl status  mysqld.service
● mysqld.service - MySQL Server
   Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
   Active: activating (start) since Mon 2016-11-14 12:29:52 IST; 1s ago
  Process: 11561 ExecStartPre=/usr/bin/mysqld_pre_systemd (code=exited, status=0/SUCCESS)
  Control: 11590 (mysqld)
    Tasks: 14 (limit: 512)
   CGroup: /system.slice/mysqld.service
           ├─11590 /usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid
           └─11594 /usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid

Nov 14 12:29:52 localhost.localdomain systemd[1]: Starting MySQL Server...
Nov 14 12:29:54 localhost.localdomain mysqld_pre_systemd[11561]: 2016-11-14T06:59:54.106197Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is depr
Nov 14 12:29:54 localhost.localdomain mysqld_pre_systemd[11561]: 2016-11-14T06:59:54.110702Z 0 [ERROR] --initialize specified but the data directory h
Nov 14 12:29:54 localhost.localdomain mysqld_pre_systemd[11561]: 2016-11-14T06:59:54.110778Z 0 [ERROR] Aborting
 ESCOC

Thanks a lot.

edit retag flag offensive close merge delete

Comments

Mysql is not supported on Fedora, you can use MariaDB out of the box, Mysql is supported by Oracle any issue should be address by them

aeperezt gravatar imageaeperezt ( 2016-11-14 07:43:49 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-11-14 09:32:20 -0500

hhlp gravatar image

That is a warning how to solved this warning is here, can you redit your post an post with the result of this command? it seems you have another error but you cut some important part,:

systemctl status mysql -l

try don't cut any important part.

you should look at this :

you can look your messages there :

Those nonstandard behaviors remain the default for TIMESTAMP but as of MySQL 5.6.6 are deprecated and this warning appears at startup:

[Warning] TIMESTAMP with implicit DEFAULT value is deprecated.
Please use --explicit_defaults_for_timestamp server option (see
documentation for more details).

you have to add this line in your my.cnf in the [mysqld] section.

explicit_defaults_for_timestamp = 1

Regards.,

NOTE : all information an error you can find here -> refman/5.7

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-11-14 01:12:54 -0500

Seen: 170 times

Last updated: Nov 14 '16