Ask Your Question
0

iBUS doesn't work in fedora 18

asked 2013-01-24 03:31:51 -0500

banglh gravatar image

updated 2013-01-24 05:19:32 -0500

hhlp gravatar image

I've just install fedora 18 for a few days and I'm trying to use ibus-unikey. But it doesn't work. ibus shotcut doesn't show on the taskbar. There are packages that I have after installation:

ibus-gtk2-1.4.99.20121109-9.fc18.x86_64
ibus-1.4.99.20121109-9.fc18.x86_64
ibus-gtk3-1.4.99.20121109-9.fc18.x86_64
ibus-libs-1.4.99.20121109-9.fc18.x86_64
ibus-unikey-0.6.1-2.fc17.x86_64

After installation, I start ibus with command ibus-setup to set up keyboard layout and input method. Then I excute the command ibus-daemon and insert 3 lines into .bashrc:

  export GTK_IM_MODULE=ibus
  export XMODIFIERS=@im=ibus
  export QT_IM_MODULE=ibus

But nothing happened. Please help me to solve this problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-24 15:40:43 -0500

kimbn gravatar image

Are you using Gnome desktop? ibus has been integrated into Gnome, and you can't run external ibus anymore. The Fedora 18 Release Notes has some explanation on how to setup input sources for different languages.

Warning: the integrated ibus is not good yet. The switching speed is slow.

edit flag offensive delete link more

Comments

when i rock back to gnome2 ( fall backmode) ,the ibus can't auto start ?

yanxinyou gravatar imageyanxinyou ( 2013-03-27 08:01:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-24 03:31:51 -0500

Seen: 1,328 times

Last updated: Jan 24 '13