Ask Your Question
1

Fedora upgrade 24 to 25, auto login not working under wayland

asked 2016-11-27 08:14:13 -0500

thingummybob gravatar image

updated 2016-11-27 08:39:14 -0500

Is anyone else experiencing issues with auto login in Gnome on F25? Or is it just my install that's mangled? Please note that I used the method recommended on the Fedora Project wiki:

$ sudo fedora-upgrade

and then single user mode

# dnf upgrade

I try not to jump all over issues when I've installed a brand new release version - it's probably better to wait a bit for niggles to get ironed out, but this issue and one other are starting to irritate, and I want to be sure I didn't screw up either the upgrade, or whether this issue could be related to the fact that I subsequently installed the Nvidia drivers, which note now seem to have been written to work with Wayland, but which have broken the Plymouth boot splash (also noted by others).

I've read around a bit, including the bug tracker forums etc. and can confirm that I'm running the default Wayland session under Gnome, and note that others have some issues regarding logging in (at all) under these same versions. If I am to try to troubleshoot this, would this be anything this forum can help with, or do I need to be posting over on Gnome or GTK support, or whether I should just wait a few days because a fix is coming?

edit retag flag offensive close merge delete

Comments

Auto login in Gnome on F25 do not work here.

deusdara gravatar imagedeusdara ( 2016-11-27 09:07:34 -0500 )edit

I encounter the same problem after upgrading from Fedora 24 to Fedora 25: automatic login is not working anymore :(

gwendal gravatar imagegwendal ( 2016-12-18 03:47:01 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-18 04:44:40 -0500

gwendal gravatar image

This problem seems indeed related to Wayland. In my case, the problem disappeared after setting WaylandEnable=false in /etc/gdm/custom.conf (which means going back to X11 for the login screen).

There seemed to be a bug opened here: https://bugzilla.gnome.org/show_bug.c...

edit flag offensive delete link more

Comments

Sure, I see that. But since posting, I've decided to just give up on Wayland and wait for F28 or F29 - when one imagines all these thousands of people between Gnome and Wayland and Fedora can agree on something ;0) I'll live with the annoying niggles because they're precisely that - annoying. I just installed Arch on a laptop, and after finally deciding to use Gnome as the DE, began to see just how unfinished Wayland is. I was rather forced to use this same "enable=false" config as otherwise just the basic touchpand doesn't work properly. Hey - it didn't cost anything, right?!

thingummybob gravatar imagethingummybob ( 2016-12-20 16:54:30 -0500 )edit

@gwendal I should also point out that yes, yours is the answer, thank you. I was using that .conf option on the laptop but not my desktop. Just edited it and bingo! Nice :0)

thingummybob gravatar imagethingummybob ( 2016-12-21 05:04:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-27 08:14:13 -0500

Seen: 2,146 times

Last updated: Nov 27 '16