Ask Your Question
3

vlc picture freezes on Fedora 25

asked 2016-12-08 22:43:47 -0500

technog1 gravatar image

Had installed vlc on an earlier version of Feodra. Vlc used to work fine. Updated to 25. Now vlc has odd behavior and becomes non-responsive.

While playing a video In full screen mode, i attempt to move cursor over the progress indicator bar to move playback position of video. As I am moving the cursor over the slider bar, the whole machine becomes unresponsive.

The video is frozen, but the soundtrack continues to play as normal. I cannot move the cursor anymore. Nor can i take focus away from the vlc screen. alt-tab to window doesnt work cltrl-alt-del doesnt work esc doesnt work

I have to hard power down the machine. This has been happening a lot.

tia,

Sunny

edit retag flag offensive close merge delete

Comments

Since my upgrade from 24 to 25, vlc has been misbehaving much more than it used to. It might play 2 to 5 videos in a row just fine and then incorrectly zoom the next one and/or freeze the video but continue to play the audio. However, Gnome continues to function okay so I can open a terminal window and look for a vlc process to kill. (Attempting to closing the window does not work nor does it stop the piece which plays the audio.) Then it works okay.

wallyk gravatar imagewallyk ( 2016-12-09 00:38:47 -0500 )edit

the vlc from rpmfusion disabled the scaling with wayland... report it in rpmfusion or you can install vlc from unitedrpms but you need disable rpmfusion...

davidva gravatar imagedavidva ( 2017-06-05 03:03:45 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-08 23:47:03 -0500

geforce gravatar image

Are you using gnome wayland session?, if so try using X

edit flag offensive delete link more

Comments

This is also happening to me. I am using X under fedora25. I will check it out under wayland.

nmg

nmgiffin gravatar imagenmgiffin ( 2017-06-04 10:57:23 -0500 )edit
0

answered 2017-08-12 23:56:40 -0500

just use it via command line with cvlc video.videoformat, this should works.

edit flag offensive delete link more

Comments

or /usr/bin/vlc-wrapper

pietrod gravatar imagepietrod ( 2017-08-16 14:16:35 -0500 )edit
0

answered 2017-06-04 17:02:54 -0500

nmgiffin gravatar image

This seems to have been an old issue that hasn't really gone away. 6 months since orig post. I can't say for the original poster, but for me it was freezing under X but seems to run okay under wayland on vmlinuz-4.11.3-200.fc25.x86_64 nmg

edit flag offensive delete link more

Comments

Not true. I spoke too soon. It exhibits this freezing trait under both X and Wayland. nmg

nmgiffin gravatar imagenmgiffin ( 2017-06-04 17:31:15 -0500 )edit

vlc has various settings for decoding video (hardware accelerated decoding with vdpau or va-api and so on), have you tried all of them? What's your video hardware and drivers?

fcomida gravatar imagefcomida ( 2017-06-04 18:47:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-08 22:43:47 -0500

Seen: 1,068 times

Last updated: Jun 04 '17