Ask Your Question
0

unable to set ulimit -n above 4096

asked 2016-12-16 10:33:25 -0600

jmbnyc gravatar image

I want to set ulimit -n to 65535 for all users.

The procedure I have follow has worked on every linux distro up until fedora 25. There must be something in the gdm logon process that is limiting the setting.

I followed all of the instructions here: https://www.cyberciti.biz/faq/linux-i... but it does not work.

Does anyone have a clue what magic is required to overcome this problem?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2016-12-16 14:06:29 -0600

ed209 gravatar image

Change soft and hard limits in /etc/security/limits.conf.

Why are you requiring such a large limit for all users?

edit flag offensive delete link more
0

answered 2017-04-12 10:14:51 -0600

Not sure if this was ever answered to your liking, but this is now controlled by systemd. However, it also appears systemd is somehow broken and can't update the process limit above 1024, which is what I am interested in...

edit flag offensive delete link more
0

answered 2016-12-16 15:14:48 -0600

jmbnyc gravatar image

I have the soft and hard limits set appropriately - actually I tried everything with no luck.

@jmb soft nofile 65535 @jmb hard nofile 65535 * soft nofile 65535 * hard nofile 65535 root soft nofile 65535 root hard nofile 65535

And I need a lot of open files for testing but that question really has nothing to do with understanding why fedora 25 will not allow limits above 4096. I've been running fedora/redhat for close to 20 years and I have always been able to set limits (core size, stack size, open file and core pattern are the ones that matter for me).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-12-16 10:33:25 -0600

Seen: 997 times

Last updated: Dec 16 '16