Ask Your Question
1

Install VLC on Fedora 25

asked 2016-12-17 09:29:20 -0500

Sina Deuxshiri gravatar image

Hello. I'm very new to linux. I want to install vlc on Fedora 25. i used this article and i did it step by step. but when I write this command:

sudo yum install vlc

Result is: No package vlc availabe. help me plz. merci.

edit retag flag offensive close merge delete

Comments

1

What's the output of sudo dnf repolist?

bitwiseoperator gravatar imagebitwiseoperator ( 2016-12-17 13:30:42 -0500 )edit
1
florian gravatar imageflorian ( 2016-12-18 16:48:21 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2016-12-17 16:45:44 -0500

steveebey73742 gravatar image

updated 2016-12-18 15:02:15 -0500

Follow these step, and the repos RPM Fusion free and non free with all the latest builds will be insalled. vlc is part of those builds.

start terminal

sudo -i
dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
dnf install vlc

When prompted about the key, answer Y to accept, and the install should be fine

if you want mozilla support, then do dnf install mozilla-vlc

Enjoy!!

edit flag offensive delete link more

Comments

Thank you for your answer. but it didn't work. the output is:

[deuxshiri@fedora yum.repos.d]$ sudo -i

[root@fedora ~]# dnf install https://download1.rpmfusion.org/free/... -E %fedora).noarch.rpm htps://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm Warning: failed loading '/etc/yum.repos.d/atrpms.repo', skipping. Last metadata expiration check: 0:11:11 ago on Sun Dec 18 17:29:06 2016. Curl error (1): Unsupported protocol for htps://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-25.noarch.rpm [

Sina Deuxshiri gravatar imageSina Deuxshiri ( 2016-12-18 08:11:22 -0500 )edit
1

answered 2016-12-18 15:03:06 -0500

steveebey73742 gravatar image

Sorry, had a typo in the command htps instead of https. fixed it. try again. should be fine now.

edit flag offensive delete link more
0

answered 2017-02-27 21:13:40 -0500

pmc gravatar image

when you do copy paste first you must type sudo then do copy paste twice the first ime only will take (-i) the second one will take the full long command i follow the steps and itworked for me on fedora 25 thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-17 09:29:20 -0500

Seen: 28,914 times

Last updated: Dec 18 '16