Ask Your Question
0

Error Mount HD in fstab in Fedora25

asked 2016-12-23 10:36:49 -0500

Orriginal gravatar image

So after a fresh install of Fedora25 workstation I went to edit fstab file to mount my 2nd harddisk as usual. - I know that Fedora25 now auto mounts anyway but every time I went to access it, I was asked for the Root password and i don't want that to happen

So I added the line to fstab /dev/sdb1 /DATA ext4 defaults 0 1 ( /dev/sdb1 was listed in lsblk command)

On reboot this caused a boot failure and I had to rem out the line in vi while in command line mode If I change it to end in 0 0 it Boots OK but still asks me for a password to access the Disk This line used to work in Fedora 20 - 24 so any ideas about what has changed and how to auto mount this disk without being asked for a password please Thanks in advance

edit retag flag offensive close merge delete

Comments

I figured that as the drive was being auto mounted, maybe this was the problem...so I went into UTILITIES / DISKS and turned off Auto mount. then I went into fstab file to add my own mount and found that the following line had been added to fstab

/dev/disk/by-uuid/464e******/mnt/464e***** auto nosuid,nodev,nofail,x-gvfs-show 0 0

This line Still mounted the drive in book up ! ( I have hidden the full UU And so, I am still l being asked for a password to access the drive. i do NOT want users of this disk to know the root password but they need access HELP lol

Orriginal gravatar imageOrriginal ( 2016-12-23 14:38:47 -0500 )edit

If I am reading this correctly, the disk is actually mounting, but access to the mount point is requiring the root password - if that is the case, it is a permission problem on the mount point. Check that the DATA folder has appropriate access permissions for the users you expect to use it - use chown and chmod to correct accordingly.

If I am misinterpreting your issue, then my apologies. Also, if you need further guidance on the how to do this then let me know.

snowolfe gravatar imagesnowolfe ( 2016-12-24 06:32:38 -0500 )edit

Hi - I understand what you are saying there but DATA is actually the label for the complete Hard disk...and it never used to ask for permissions on previous versions of Fedora...the problem has been solved now though but THANKYOU for your response.....

Orriginal gravatar imageOrriginal ( 2016-12-25 03:59:52 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-24 05:37:52 -0500

thingummybob gravatar image

One way I can suggest - not saying it's an 'official' method:

unmount the offending disk(s). Edit your fstab and delete anything written after the system drive mounts. Save and close.

Go to "disks" and you should see the device listed on left pane. When you select it, it will become active in the main window. Click on the right-hand tab "additional partition options" and select "edit mount options" ensure that the first option "automatic mount options" is switched OFF. It may ask for passwds during these operations. Once you turn off automatic mount, you gain access to all the options below. It's possible that the option for "require additional permissions" is set, in which case unset it. You'll notice that in this dialogue you can then choose all your other mount options: mount point, disk-by UUID or Dev etc. Set these as you wish. Exit the dialogue and then mount the disk using the left hand button. Once you're set, it should now apply these options every time you start up i.e. not asking for passwords.

edit flag offensive delete link more

Comments

you WONDERFUL GENIUS - THANK YOU - you did it..works a treat..took a couple of changes..like I have to re-click the tick box to mount at start up even though the ON - OFF Auto mount buttons were set to OFF A little confusing really but I can now access it with no password required..PROBLEM SOLVED Sending you the Best Yuletide season greetings and may your socks for ever stay dry ;-)

Orriginal gravatar imageOrriginal ( 2016-12-24 11:57:17 -0500 )edit

Unfortunately it defies the original idea - mounting to fstab makes the drive available to all users. Automount mounts it inside /run/user, being available only to one particular user, just like an usb drive. Moreover it's not working automatically - perhaps the drive is GPT partitioned.

ed209 gravatar imageed209 ( 2016-12-24 20:25:28 -0500 )edit

afraid I can't help you on that bit... I have just a standard set up. I imagine though that if you click around the various settings you may get it to behave as you wish. Main thing I took from it (having done this myself) was to let Disks write to fstab rather than myself. That said, I have amended fstab afterwards, but only to add things like x-gvfs-hide to remove a drive from the folder menu. Have you read man pages for both 'mount' and 'fstab'? Good luck! ;0)

thingummybob gravatar imagethingummybob ( 2016-12-25 02:13:26 -0500 )edit
0

answered 2016-12-24 20:29:03 -0500

ed209 gravatar image

If it's not mounted at boot time like I wrote then your drive is NOT sdb1, quite simple. And as others observed, /DATA has wrong permissions, probably 700. Why are you not using UUID? Post the results of fdisk -l .

edit flag offensive delete link more

Comments

it was listed as sdb1 when I used lsblk command... And the relevent result for fdisk -l is Disk /dev/sdb: 149 GiB, 160000000000 bytes, 312500000 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disklabel type: dos Disk identifier: 0xd9182d71

Orriginal gravatar imageOrriginal ( 2016-12-25 04:06:27 -0500 )edit
0

answered 2016-12-23 11:45:31 -0500

ed209 gravatar image

This way your fstab will never work. If you do not want to utilise the UUID (why?) but the explicit device instead, your fstab line should read something like:

/dev/sdb1 /DATA ext4 defaults 1 2

The sixth field (the last one) should be 1 only for root filesystem, otherwise set it to 2. 0 is for swap, or to avoid fsck. man fstab for explanations.

edit flag offensive delete link more

Comments

As I mentioned in the post, the fstab HAS worked on previous versions of Fedora and now doesn't but NOW in Fedora 25, the Disks are mounted anyway...but I want to avoid being asked for a password everytime......

Orriginal gravatar imageOrriginal ( 2016-12-23 11:50:35 -0500 )edit

And just so you know and to rule out any error on my part, I did what you suggested and on reboot, the system went into Emergency mode ! I can only assume this is because the system is already mounting the drive.....

Orriginal gravatar imageOrriginal ( 2016-12-23 12:07:46 -0500 )edit

THE ABOVE IS NOT AN ANSWER - SORRY

Orriginal gravatar imageOrriginal ( 2016-12-23 12:15:11 -0500 )edit
0

answered 2016-12-24 20:27:46 -0500

ed209 gravatar image

If it's not mounted at boot time like I wrote then your drive is NOT sdb1, quite simple. And as others observed, /DATA has wrong permissions, probably 700. Why are you not using UUID? Post the results of fdisk -l .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-23 10:36:49 -0500

Seen: 1,016 times

Last updated: Dec 24 '16