Ask Your Question
0

Gnome does not start properly on nvidia gtx 1060 with rpmfusion drivers

asked 2017-01-08 20:23:46 -0500

LWP gravatar image

updated 2017-01-09 07:21:10 -0500

Hello,

I am still trying to get my external monitor working on optimus notebook with Fedora 25. I installed rpmfusion drivers after a clean install of Fedora. I am getting the login screen, but after I attempt to login only a black screen and some HD activity. I can switch to console though.

Here is my nvidia bug report, before I follow grubby --update-kernel=$(uname -r) --args="nvidia-drm.modeset=1" --remove-args="video=vesa:off" :

https://paste.fedoraproject.org/52364...

If I add it to the grub, the system is stuck for a longer time before displaying login screen (after wlp2s0: link becomes ready message, if I remove "quiet" from kernel options) and just blinks HD drive with about 2 Hz. Then it stops and I could generate this report (too big for the fpaste, probably contains old logs):

https://mega.nz/#!0Up3WaqB!nHX19Vund8...

edit retag flag offensive close merge delete

Comments

Your log indicates that you used the nvidia.com driver first.

/etc/X11/xorg.conf.d/99-nvidia-modules.conf isn't from rpmfusion, in fact it's from negativo repo

https://github.com/negativo17/nvidia-...

geforce gravatar imagegeforce ( 2017-01-09 03:07:35 -0500 )edit

Yes, I did, but then X wouldn't start at all. So I performed uninstall and system was successfully running on Intel. Then I played with bumblebee, uninstalled and then played with nvidia from rpmfusion. Does it seem like the original drivers didn't uninstall properly? What should I do?

LWP gravatar imageLWP ( 2017-01-09 03:13:36 -0500 )edit

OK, reinstalled fedora and attempted rpmfusion just after dnf update. I updated the original post to reflect this and my bug report is at: https://paste.fedoraproject.org/52364...

LWP gravatar imageLWP ( 2017-01-09 06:45:10 -0500 )edit
geforce gravatar imagegeforce ( 2017-01-09 11:40:57 -0500 )edit

If I see properly, I added them, as can be seen in the second log: Kernel command line: BOOTIMAGE=/vmlinuz-4.8.15-300.fc25.x8664 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rhgb nouveau.modeset=0 rd.driver.blacklist=nouveau nvidia-drm.modeset=1

LWP gravatar imageLWP ( 2017-01-09 18:51:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-19 00:59:13 -0500

LWP gravatar image

I ended up installing proprietary Nvidia drivers with this guide: https://www.if-not-true-then-false.co... (just keep in mind that the secure boot has to be switched off, otherwise there is a nvidia-dkm error during the install) and then changing the /etc/X11/xorg.conf to

https://gist.github.com/marcioAlmada/...

(Thanks to Marcio Almada for help)

and then the desktop starts. I had some problems with recovering from suspend. I didn't test the solution thoroughly yet, but it seems that the solution from this page:

https://help.ubuntu.com/community/Bin...

works.

Perhaps this solution could work with bumblebee, but since I don't know much on xorg.conf and the support from Fedora people is almost non-existent, I will skip trying it for now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-08 20:23:46 -0500

Seen: 3,243 times

Last updated: Jan 09 '17