Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How get CUDA 9.2 working on Fedora 28

I am trying to run cuda 9.2 (for tensorflow) after upgrading to fedora 28, for testing the installation while compiling the cuda 9.2 samples the compilation failed, CUDA not yet support newer gcc, * fc 28 does not allow installation of gcc older than gcc8. for initial patch up I followed the process mentioned in : https://carterturn.com/h/Guides/NVIDIA%20CUDA%209.1%20with%20GCC%207.2 as on fedora 27 it got the cuda 9.1 with gcc6 running for me but still the compilation is failing with " /c++/8/utility(311): error: pack expansion does not make use of any argument packs"
is there any way around or solution to get cuda-9.2 running on fedora 28?

How get CUDA 9.2 working on Fedora 28

I am trying to run cuda 9.2 (for tensorflow) after upgrading to fedora 28, for testing the installation while compiling the cuda 9.2 samples the compilation failed, CUDA not yet support newer gcc, * & fc 28 does not allow installation of gcc older than gcc8. for initial patch up I followed the process mentioned in : https://carterturn.com/h/Guides/NVIDIA%20CUDA%209.1%20with%20GCC%207.2 https://carterturn.com/h/Guides/NVIDIA%20CUDA%209.1%20with%20GCC%207.2

as on fedora 27 it got the cuda 9.1 with gcc6 running for me but still the compilation is failing with " /c++/8/utility(311): error: pack expansion does not make use of any argument packs"
is there any way around or solution to get cuda-9.2 running on fedora 28? 28?