Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Cannot start wayland from gdm

In previous versions of Fedora I've been using gnome-xorg for the desktop session. So in e.g. Fedora 27 I've selected to login from gdm with an xorg session. I've upgraded to Fedora 28, but can't remember what I did to still continue running xorg. After using Fedora 28 for a while I wanted to try wayland again. But now there is no option in gdm to select wayland (I know it is supposed to be default). And even though I set WaylandEnable=true in /etc/gdm/custom.conf, it doesn't start wayland. The only way to start wayland is to open another console and run "dbus-run-session -- gnome-shell --display-server --wayland". This works. I also have nvidia drivers from negativo17 installed and use nvidia-drm.modeset=1 in kernel command line.

Somehow gdm isn't even trying to launch a wayland session when logging in. Is there a way to force it somehow?

I also upgraded the system to Fedora 29, but the problem is still the same.

There are no errors in the journal and only gdm-x-session entries about starting xorg. Nothing about wayland.

Cannot start wayland from gdm

In previous versions of Fedora I've been using gnome-xorg for the desktop session. So in e.g. Fedora 27 I've selected to login from gdm with an xorg session. I've upgraded to Fedora 28, but can't remember what I did to still continue running xorg. After using Fedora 28 for a while I wanted to try wayland again. But now there is no option in gdm to select wayland (I know it is supposed to be default). And even though I set WaylandEnable=true in /etc/gdm/custom.conf, it doesn't start wayland. The only way to start wayland is to open another console and run "dbus-run-session -- gnome-shell --display-server --wayland". This works. I also have nvidia drivers from negativo17 installed and use nvidia-drm.modeset=1 in kernel command line.

Somehow gdm isn't even trying to launch a wayland session when logging in. Is there a way to force it somehow?

I also upgraded the system to Fedora 29, but the problem is still the same.

There are no errors in the journal and only gdm-x-session entries about starting xorg. Nothing about wayland.