Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Soundblaster ZxR + Fedora 29 = no sound.

aplay -L shows null Discard all samples (playback) or generate zero samples (capture) pulse PulseAudio Sound Server default Default ALSA Output (currently PulseAudio Sound Server) hdmi:CARD=HDMI,DEV=0 HDA ATI HDMI, HDMI 0 HDMI Audio Output hdmi:CARD=HDMI,DEV=1 HDA ATI HDMI, HDMI 1 HDMI Audio Output hdmi:CARD=HDMI,DEV=2 HDA ATI HDMI, HDMI 2 HDMI Audio Output hdmi:CARD=HDMI,DEV=3 HDA ATI HDMI, HDMI 3 HDMI Audio Output hdmi:CARD=HDMI,DEV=4 HDA ATI HDMI, HDMI 4 HDMI Audio Output sysdefault:CARD=Creative HDA Creative, CA0132 Analog Default Audio Device front:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog Front speakers surround21:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 2.1 Surround output to Front and Subwoofer speakers surround40:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 4.0 Surround output to Front and Rear speakers surround41:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Creative,DEV=0 HDA Creative, CA0132 Analog 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Creative,DEV=0 HDA Creative, CA0132 Digital IEC958 (S/PDIF) Digital Audio Output

Under Windows it works properly. I use headphone and in the alsamixer I set it up (I heard the "click" when it changed). Please help me. I'm berginner and I need exact answers with example about what can I do.

uname -a Linux localhost.localdomain 4.19.2-300.fc29.x86_64 #1 SMP Wed Nov 14 19:05:24 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

dmesg -t | grep snd snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client snd_hda_intel 0000:01:00.1: Force to non-snoop mode snd_hda_intel 0000:03:00.0: enabling device (0000 -> 0002) snd_hda_intel 0000:03:00.0: Disabling MSI snd_hda_intel 0000:03:00.0: Force to non-snoop mode snd_hda_codec_ca0132 hdaudioC1D1: autoconfig for Sound Blaster Z: line_outs=3 (0xb/0x11/0x10/0x0/0x0) type:line snd_hda_codec_ca0132 hdaudioC1D1: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) snd_hda_codec_ca0132 hdaudioC1D1: hp_outs=1 (0xf/0x0/0x0/0x0/0x0) snd_hda_codec_ca0132 hdaudioC1D1: mono: mono_out=0x0 snd_hda_codec_ca0132 hdaudioC1D1: dig-out=0xc/0xd snd_hda_codec_ca0132 hdaudioC1D1: inputs: snd_hda_codec_ca0132 hdaudioC1D1: Mic=0x12 snd_hda_codec_ca0132 hdaudioC1D1: Line=0x13 snd_hda_codec_ca0132 hdaudioC1D1: dig-in=0xe snd_hda_intel 0000:03:00.0: Direct firmware load for ctefx-sbz.bin failed with error -2 snd_hda_codec_ca0132 hdaudioC1D1: ca0132 DSP downloaded and running