Ask Your Question

Revision history [back]

Unable to boot Fedora 29 on Mac Pro

Hello crew,

I have a bit of a pet project, it's a 2006 Apple Mac Pro 1,1, upgraded with the parts and firmware from a higher-end 2007 Mac Pro 2,1. I'd like to use it to try and get back into doing more work for the Fedora project around package maintenance.

The Fedora installer won't boot on this machine. I suspect it may be due to it's 32-bit EFI. I know Fedora supports 32-bit EFIs specifically https://fedoraproject.org/wiki/Changes/32BitUefiSupport however this machine won't boot the installer, and I'm hoping someone can help me understand why.

When I start the machine with a Fedora Workstation install USB in, I get the black-white GRUB menu showing Start Fedora-Workstation-Live-29, Test this media & start Fedora-Workstation-Live 29, and Troubleshooting entries. I can navigate this menu and select any option, but all that happens is a still cursor, the activity LED on my USB drive flashes for some seconds (feels like about 60 seconds?), then the machine reboots.

So far: - tried a bunch of different USBs, including USB 2.0 drives - confirmed ISOs i've downloaded hash correctly - tried a bunch of different options in Rufus, unetbootin, etcher no change - installed the Fedora Media Writer and tried that, no change - went through the process described on mattgadient's blog page ( to modify the Fedora 29 netinstall iso, burned it to a CD, booted and installed that successfully - but it only supports MBR installs, and runs in a special mode intended for Windows which causes odd behaviors. I want a native EFI install so I can use the hardware completely. - I've done a fair bit of googling around and finding that there are some who are successfully using pure EFI boots/installs running Linux. I've also read up on how (U)EFI works here, though to be fair I stopped shortly after "Fallback path’ UEFI native boot entries" because not booting from removable media is as far as I've gotten.

FWIW, I'm able to install MacOS versions this hardware supports without any trouble and run them OK.

Any input appreciated. I'll try to update this blog post if I make progress on my own.