Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

unbelievably, extremely slow boot time

Hi All,

I'm installing Linux on an older HP Laptop for my father so he can continue getting updated web browser. Chrome/Firefox no longer update on his mac. I've been installing many flavors of Fedora to see which I can make east for an 80-year-old Mac person to use.

Note: Earlier today I tried installing Ubuntu. It asked about installing a boot loader is there were to be more than one OS on the computer. I declined to install anything, but I think that may have been where the problem started.

I settled on Fedora with Cinnamon desktop. When I installed it a few days ago it worked great, booted great, and was modifyable enough that Dad could use it without confusion.\

However, after reinstalling today, the boot time became STUNNINGLY SLOW. I mean, go cook lunch slow.

I promised I'd have this done for tomorrow's visit, but this boot problem is killing me.

I'll attach some diagnostics. First, inxi -Fxz, and then systemd-analyze blame (Quite long -- 75 lines). What's killing me is it seems to be different things appearing in this list. Plymoth is always there, but I've seen initd.service at the top, as well as others that I can't remember. Let me know if there's other information I can post. I'm quite lost at this level of problem solving, so if you have a suggestion, please be as explicit as you can. "Put a cli option on your grub init file" won't help me, but "Edit /etc/init/grub and add the line system.grub=ini" would be wonderfully helpful.

(UPDATE with more. even slower information at bottom)

System: Host: laptop Kernel: 4.18.16-300.fc29.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Cinnamon 3.8.9 Distro: Fedora release 29 (Twenty Nine) 
Machine: Type: Laptop System: Hewlett-Packard 
  product: HP Compaq 6510b (GZ438UP#ABA) v: F.10 serial: <filter> 
  Mobo: Hewlett-Packard model: 30C0 v: KBC Version 71.2E serial: <filter> 
  BIOS: Hewlett-Packard v: 68DDU Ver. F.10 date: 01/11/2008 
Battery: ID-1: C23B charge: 44.0 Wh condition: 44.0/44.0 Wh (100%) 
  model: Hewlett-Packard Primary status: Full 
CPU: Topology: Dual Core model: Intel Core2 Duo T7100 bits: 64 type: MCP 
  arch: Core Merom rev: D L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 7181 
  Speed: 798 MHz min/max: 800/1801 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics: Device-1: Intel Mobile GM965/GL960 Integrated Graphics driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: Fedora Project X.org 11.0 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1280x800~60Hz 
  OpenGL: renderer: Mesa DRI Intel 965GM v: 2.1 Mesa 18.2.2 
  direct render: Yes 
Audio: Device-1: Intel 82801H HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.18.16-300.fc29.x86_64 
Network: Device-1: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network 
  driver: iwl4965 v: in-tree:d bus ID: 10:00.0 
  IF: wlp16s0 state: up mac: <filter> 
  Device-2: Broadcom and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI 
  Express 
  driver: tg3 v: 3.137 port: N/A bus ID: 18:00.0 
  IF: ens1 state: down mac: <filter> 
Drives: Local Storage: total: 74.53 GiB used: 5.87 GiB (7.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST980811AS size: 74.53 GiB 
Partition: ID-1: / size: 47.02 GiB used: 5.54 GiB (11.8%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot size: 975.9 MiB used: 144.8 MiB (14.8%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 22.95 GiB used: 198.6 MiB (0.8%) fs: ext4 dev: /dev/dm-2 
  ID-4: swap-1 size: 2.07 GiB used: 12 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors: System Temperatures: cpu: 38.0 C mobo: 24.9 C 
  Fan Speeds (RPM): N/A 
Info: Processes: 192 Uptime: 27m Memory: 1.94 GiB used: 1.08 GiB (55.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  inxi: 3.0.24 

systemd-analyze blame

systemd-analyze blame

 1min 3.977s dracut-initqueue.service
     31.171s colord.service
     26.846s plymouth-switch-root.service
     18.162s firewalld.service
     16.355s udisks2.service
     11.622s sssd.service
      9.993s abrtd.service
      6.593s avahi-daemon.service
      6.296s rsyslog.service
      6.295s lm_sensors.service
      6.289s bluetooth.service
      6.268s iio-sensor-proxy.service
      5.772s gssproxy.service
      5.644s initrd-switch-root.service
      5.512s polkit.service
      5.448s systemd-udev-settle.service
      5.373s rtkit-daemon.service
      5.098s chronyd.service
      4.944s livesys-late.service
      4.942s lvm2-monitor.service
      4.469s accounts-daemon.service
      2.261s lvm2-pvscan@8:2.service
      2.225s systemd-fsck-root.service
      1.423s systemd-journal-flush.service
      1.362s cups.service
      1.359s systemd-fsck@dev-mapper-fedora_laptop\x2dhome.service
      1.358s systemd-logind.service
      1.205s lightdm.service
      1.048s systemd-fsck@dev-disk-by\x2duuid-76ca2629\x2de3e6\x2d4ee5\x2da>
       983ms systemd-udev-trigger.service
       972ms systemd-udevd.service
       907ms dnf-makecache.service
       797ms NetworkManager.service
       741ms dmraid-activation.service
       733ms systemd-tmpfiles-setup-dev.service
       686ms auditd.service
       645ms systemd-rfkill.service
       571ms systemd-vconsole-setup.service
       559ms upower.service
       540ms kmod-static-nodes.service
       506ms systemd-remount-fs.service
       501ms systemd-sysctl.service
       465ms sys-kernel-debug.mount
       446ms livesys.service
       421ms import-state.service
       402ms user@1000.service
       395ms dev-hugepages.mount
       361ms systemd-tmpfiles-setup.service
       361ms wpa_supplicant.service
       356ms dev-mapper-fedora_laptop\x2dswap.swap
       339ms dev-mqueue.mount
       299ms dracut-cmdline.service
       271ms nfs-config.service
       249ms sysroot.mount
       233ms initrd-parse-etc.service
       229ms systemd-journald.service
       216ms systemd-tmpfiles-clean.service
       203ms systemd-random-seed.service
       194ms rpc-statd-notify.service
       185ms boot.mount
       177ms dracut-pre-pivot.service
       168ms systemd-user-sessions.service
       166ms systemd-backlight@backlight:acpi_video0.service
       151ms plymouth-read-write.service
       122ms var-lib-nfs-rpc_pipefs.mount
        87ms dracut-shutdown.service
        68ms systemd-update-utmp.service
        61ms home.mount
        43ms dracut-pre-udev.service
        36ms initrd-cleanup.service
        32ms plymouth-start.service
        21ms systemd-backlight@backlight:intel_backlight.service
        20ms systemd-update-utmp-runlevel.service
        19ms tmp.mount
        19ms initrd-udevadm-cleanup-db.service
         8ms sys-kernel-config.mount

UPDATE: I put in the Ububtu Live DVD and booted, and got this from systemd-analyze blame:

   2min 18.417s ubiquity.service
     2min 5.790s snapd.seeded.service
    1min 34.739s plymouth-quit-wait.service
    1min 13.391s dev-sr0.device
     1min 9.025s snapd.hold.service
         58.572s networkd-dispatcher.service
         40.441s NetworkManager.service
         38.481s ModemManager.service
         37.661s udisks2.service
         31.020s dev-loop0.device
         29.368s systemd-resolved.service
         27.741s rsyslog.service
         25.721s wpa_supplicant.service
         24.896s networking.service
         22.920s thermald.service
         22.256s accounts-daemon.service
         18.699s apport.service
         18.665s grub-common.service
         17.931s gpu-manager.service
         16.883s avahi-daemon.service
         16.140s systemd-rfkill.service
         13.216s NetworkManager-wait-online.service
         12.945s switcheroo-control.service
         12.935s pppd-dns.service
         12.905s systemd-logind.service
          9.651s keyboard-setup.service
          8.844s polkit.service
          6.018s packagekit.service
          5.773s bluetooth.service
          4.816s lvm2-monitor.service
          4.138s systemd-modules-load.service
          2.525s upower.service
          2.376s lvm2-pvscan@8:2.service
          2.178s systemd-udevd.service
          2.124s plymouth-start.service
          1.978s systemd-timesyncd.service
          1.886s dns-clean.service
          1.417s plymouth-read-write.service
          1.411s systemd-journald.service
          1.261s kmod-static-nodes.service
          1.235s systemd-sysusers.service
          1.148s user@123.service
          1.072s gdm.service
           989ms colord.service
           868ms systemd-update-utmp.service
           821ms grub-initrd-fallback.service
           732ms systemd-sysctl.service
           726ms systemd-tmpfiles-setup-dev.service
           627ms kerneloops.service
           601ms blk-availability.service
           539ms ifupdown-pre.service
           516ms systemd-tmpfiles-clean.service
           499ms user@999.service
           466ms systemd-remount-fs.service
           389ms ufw.service
           346ms systemd-journal-flush.service
           321ms systemd-backlight@backlight:acpi_video0.service
           275ms iio-sensor-proxy.service
           158ms systemd-udev-trigger.service
           145ms setvtrgb.service
           132ms snapd.service
           131ms systemd-random-seed.service
           112ms rtkit-daemon.service
            97ms dev-loop3.device
            88ms dev-loop4.device
            83ms dev-loop5.device
            80ms dev-loop6.device
            75ms dev-loop7.device
            68ms dev-loop1.device
            51ms dev-loop2.device
            49ms snap-gtk\x2dcommon\x2dthemes-701.mount
            49ms snap-gnome\x2dcalculator-238.mount
            48ms systemd-tmpfiles-setup.service
            47ms dev-hugepages.mount
            44ms snap-gnome\x2dcharacters-124.mount
            40ms sys-kernel-debug.mount
            37ms snap-gnome\x2d3\x2d26\x2d1604-70.mount
            35ms snap-core-5662.mount
            31ms console-setup.service
            29ms snap-gnome\x2dsystem\x2dmonitor-57.mount
            28ms snap-gnome\x2dlogs-45.mount
            16ms dev-mqueue.mount
            14ms systemd-update-utmp-runlevel.service
            11ms systemd-backlight@backlight:intel_backlight.service
            11ms tmp.mount
            10ms openvpn.service
            10ms systemd-user-sessions.service
             9ms sys-kernel-config.mount
             8ms sys-fs-fuse-connections.mount
             2ms snapd.socket