Ask Your Question

Thanos's profile - activity

2018-06-25 12:18:03 -0500 received badge  Nice Question (source)
2018-02-13 00:26:30 -0500 received badge  Editor (source)
2018-02-13 00:25:46 -0500 received badge  Supporter (source)
2018-01-26 00:50:11 -0500 received badge  Student (source)
2018-01-26 00:47:58 -0500 received badge  Popular Question (source)
2018-01-26 00:47:58 -0500 received badge  Notable Question (source)
2018-01-26 00:47:58 -0500 received badge  Famous Question (source)
2018-01-02 12:37:00 -0500 asked a question Fedora 25 - laptop won't suspend when closing lid after hard shutdown

I am facing this rather bizarre situation. After shutting down my laptop by pushing the power button for a few seconds and powering it on again the "suspend when lid is closed" option isn't working.

So when I close the lid, the laptop powers off. The strange thing is that when I open the lid the laptop powers on! This is strange because I don't push any power button whatsoever!

I checked my /etc/systemd/logind.conf file, but the following lines are uncommented

HandleLidSwitch=suspend
HandleLidSwitchDocked=suspend

Any idea on what might be the issue?

I am pasting the entire logind.conf file, because it might be useful to locate the problem.

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=suspend
HandleLidSwitchDocked=suspend
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#UserTasksMax=12288

I also upgraded my system to Fedora 27, but still the problem remains.

Additionally I tried to edit the grub file by following the steps seen below 1. $ swapon -s which gave

`Filename               Type        Size    Used    Priority
/dev/dm-2                               partition   7864316 0   -2`
  1. Then I edited the /etc/default/grub file. On the entry about GRUB_CMDLINE_LINUX= there was "rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet" which I changed to resume=/dev/dm-2

  2. To identify whether my system is UEFI or legacy I did $ sudo efibootmgr. The output was EFI variables are not supported on this system. which I guess means that I own a legacy system. So finally I did grub2-mkconfig -o /etc/grub2.cfg

I also checked the journal by typing sudo journalctl -b | grep "Feb 13" > journal.dat but I don't know how to see if there is something wrong there. The output can be found here

Any idea on how to proceed?

2017-11-22 01:03:53 -0500 commented answer Fedora 24 doesn't do anything when closing laptop lid

Make sure that you have these two lines in your /etc/systemd/logind.conf:

  1. HandleLidSwitch=suspend
  2. HandleLidSwitchDocked=suspend

Note that this works only in fedora.

2017-09-20 04:22:15 -0500 received badge  Popular Question (source)
2017-04-07 11:35:45 -0500 commented question Building qtiplot-0.9.8.9 in fedora 24

@hhlp : Thanks for your suggestion. I've sent an email and asked for it!

2017-04-07 09:37:15 -0500 commented question Building qtiplot-0.9.8.9 in fedora 24

@hhlp : I added the repository by typing dnf copr enable scorpionit/qtiplot. Then I updated the repositories sudo dnf check-update | grep qtiplot but it cannot synchronize Failed to synchronize cache for repo 'scorpionit-qtiplot', disabling

2017-04-07 09:37:14 -0500 commented question Building qtiplot-0.9.8.9 in fedora 24

@hhlp : Maybe I am confused, but I am talking about qtiplot. But If i give dnf copr search qtiplot it finds something. Since I am not familiar with this command (I've been using fedora the latest month) I don't know, how to use it to install qtiplot.

2017-04-07 07:32:53 -0500 asked a question Building qtiplot-0.9.8.9 in fedora 24

I am trying to build qtiplot-0.9.8.9 on my fedora-24 system. I have downloaded all the necessary dependencies (i.e. Qt, GSL, muParser, zlib, libpng, Qwtand qwtplot3d).

I am running qmake && make but it fails! The first error message is the following

In file included from src/analysis/NonLinearFit.cpp:32:0:
src/scripting/MyParser.cpp: In constructor ‘MyParser::MyParser()’:
src/scripting/MyParser.cpp:57:22: error: ‘getLocale’ was not declared in this scope
  setLocale(getLocale());

I checked the MyParser.cpp and surprisingly I found out that getLocale() is in there, which you can see in the following part of the file.

MyParser::MyParser()
:Parser()
{
    DefineConst("pi", M_PI);
    DefineConst("Pi", M_PI);
    DefineConst("PI", M_PI);

    for (const muParserScripting::mathFunction *i=muParserScripting::math_functions; i->name; i++){
        if (i->numargs == 1 && i->fun1 != NULL)
            DefineFun(i->name, i->fun1);
        else if (i->numargs == 2 && i->fun2 != NULL)
            DefineFun(i->name, i->fun2);
        else if (i->numargs == 3 && i->fun3 != NULL)
            DefineFun(i->name, i->fun3);
    }
    gsl_set_error_handler_off();

    setLocale(getLocale());
}

QLocale MyParser::getLocale()
{
    bool cLocale = true;
    foreach (QWidget *w, QApplication::allWidgets()){
        ApplicationWindow *app = qobject_cast<ApplicationWindow *>(w);
        if (app){
            cLocale = app->d_muparser_c_locale;
            break;
        }
    }

    QLocale locale = QLocale::c();
    if (!cLocale)
        locale = QLocale();

    return locale;
}

So I was wondering, if anyone has any idea on that?