Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

WORK AROUND:

RE: Screen rotation.

The button in the upper right drop down for screen rotation lock has no effect on screen rotation whatsoever.

Goto Settings > Devices > Display ... take notice that even though the Fedora Help application indicates there should be a screen rotation setting here that you can change, no such setting appears in this window.

TEMPORARY SOLUTION:

Open Terminal. and enter: systemctl status iio-sensor-proxy

Mine showed active. I then entered:

systemctl stop iio-sensor-proxy

After stopping iio-sensor-proxy, now go back to Settings > Devices > Display. You should now see a drop down for "Orientation." Mine showed that the orientation was in "Landscape," but it was actually in portrait when looking at the screen. Ultimately, I ended up selecting "Portrait Left" to actually put my screen orientation into landscape.

After rebooting, the setting remained in "Portrait Left" (actually keeping screen in landscape). However, on reboot, the iio-sensor-proxy did restart, though auto-rotation still does not work. BUT, with this work around, I can use the keyboard/track pad dock on my device and read the screen as if I just have a laptop without an accelorometer, so it is "useable."

A solution for getting iio-sensor-proxy to properly recognize the screen orientation and also change the screen orientation with the physical orientation of the screen still needs to be found and implemented. But I marked this as an answer for a "Work Around."

WORK AROUND:

RE: Screen rotation.

The button in the upper right drop down for screen rotation lock has no effect on screen rotation whatsoever.

Goto Go to Settings > Devices > Display ... take notice that even though the Fedora Help application indicates there should be a screen rotation setting here that you can change, no such setting appears in this window.

TEMPORARY SOLUTION:

Open Terminal. and enter: enter:

systemctl status iio-sensor-proxy

Mine showed active. I then entered:

systemctl stop iio-sensor-proxy

After stopping iio-sensor-proxy, now go back to Settings > Devices > Display. You should now see a drop down for "Orientation." Mine showed that the orientation was in "Landscape," but it was actually in portrait when looking at the screen. Ultimately, I ended up selecting "Portrait Left" to actually put my screen orientation into landscape.

After rebooting, the setting remained in "Portrait Left" (actually keeping screen in landscape). However, on reboot, the iio-sensor-proxy did restart, though auto-rotation still does not work. BUT, with this work around, I can use the keyboard/track pad dock on my device and read the screen as if I just have a laptop without an accelorometer, so it is "useable."

A solution for getting iio-sensor-proxy to properly recognize the screen orientation and also change the screen orientation with the physical orientation of the screen still needs to be found and implemented. But I marked this as an answer for a "Work Around."