Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Once you have a list to work,

with the output Artur Symczak asked for - i'd prefer the command output the other way around: systemd-analyze blame;systemd-analyze

You can disable them like this.

NOTE: This example works for me, but might not be applicable to your system!

for serv in ip6tables bluetooth \
    sendmail exim \
    livesys livesys-late \
    mdmonitor mdmonitor-takeover \
    lvm2 lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

These are common victims for my system, so i have them disabled upon first login.

click to hide/show revision 2
Added customized example

Once you have a list to work,

with the output Artur Symczak asked for - i'd prefer the command output the other way around: systemd-analyze blame;systemd-analyze

You can disable them like this.

NOTE: This example works for me, but might not be applicable to your system!

for serv in ip6tables bluetooth \
    sendmail exim \
    livesys livesys-late \
    mdmonitor mdmonitor-takeover \
    lvm2 lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

These are common victims for my system, so i have them disabled upon first login.

Edit & update: According to your output, i'd applied them this way:

for serv in fedora-loadmodules plymouth-quit-wait \
        bluetooth systemd-fsck-root \
        avahi-daemon lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

lvm2-monitor and avahi-daemon might cause an issue - i dont know. If it was my system, id run this, but then its not mine - you do at your own risk.

Once you have a list to work,

with the output Artur Symczak asked for - i'd prefer the command output the other way around: systemd-analyze blame;systemd-analyze

You can disable them like this.

NOTE: This example works for me, but might not be applicable to your system!

for serv in ip6tables bluetooth \
    sendmail exim \
    livesys livesys-late \
    mdmonitor mdmonitor-takeover \
    lvm2 lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

These are common victims for my system, so i have them disabled upon first login.

Edit & update: According to your output, i'd applied them this way:way for you:

for serv in fedora-loadmodules plymouth-quit-wait \
        bluetooth systemd-fsck-root \
        avahi-daemon lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

lvm2-monitor and avahi-daemon might cause an issue - i dont know. If it was my system, id run this, but then its not mine - you do at your own risk.

Once you have a list to work,

with the output Artur Symczak asked for - i'd prefer the command output the other way around: systemd-analyze blame;systemd-analyze

You can disable them like this.

NOTE: This example works for me, but might not be applicable to your system!

for serv in ip6tables bluetooth \
    sendmail exim \
    livesys livesys-late \
    mdmonitor mdmonitor-takeover \
    lvm2 lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

These are common victims for my system, so i have them disabled upon first login.

Edit & update: According to your output, i'd applied them this way for you:

for serv in fedora-loadmodules plymouth-quit-wait \
        bluetooth systemd-fsck-root \
        avahi-daemon lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

lvm2-monitor and avahi-daemon might cause an issue - i dont know. If it was my system, id run this, but then its not mine - you do at your own risk.

Once you have a list to work,

with the output Artur Symczak asked for - i'd prefer the command output the other way around: systemd-analyze blame;systemd-analyze

You can disable them like this.

NOTE: This example works for me, but might not be applicable to your system!

for serv in ip6tables bluetooth \
    sendmail exim \
    livesys livesys-late \
    mdmonitor mdmonitor-takeover \
    lvm2 lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

These are common victims for my system, so i have them disabled upon first login.

Edit & update: According to your output, i'd applied them this way for you:

for serv in fedora-loadmodules plymouth-quit-wait \
        bluetooth systemd-fsck-root \
        avahi-daemon lvm2-monitor
do
    systemctl stop $serv.service
    systemctl disable $serv.service
done

lvm2-monitor and avahi-daemon might cause an issue - i dont know. If it was my system, id run this, but then its not mine - you do at your own risk.