English
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Just upgraded from Fedora 21 to Fedora 22. My webserver no longer works. I installed cockpit to view system logs. It says I have a syntax error in virtual host conf file on a line with

Listen 8080

apachectl configtest says there is no syntax error

system log says there is a syntax error and that socket is not configured in "socket activation".

I have been searching for two hours to find specific information for how to configure apache 2.4 for virual hosts in a systemd environment. Instead of help from systemd people all of the "help" I find them telling me how wonderful it is, how it is supposed to work and bla, bla, bla... It doesn't work like their oversimplified explanations say. I find no direct answers to my questions. The current system "service+selinux+firewalled+systemd" is a mess with people pointing fingers at each other. Give me a break. I am just a simple guy trying to setup a simple system. Complexity is not empowering, it weakens the security, stability, reliability, and maintainability of the system. My configuration has withstood system upgrades with little change since Fedora 10. Now it is broken and the log messages are in conflict with each other. "It doesn't have a syntax error but won't start because of a syntax error."

I have simple needs:

I need the server to present normal service on port 80. The default configuration does this.

I need the service to offer local intranet traffic on port 8080. It can not longer listen on port 8080 even when I open this port in firewalld.

It shouldn't be difficult to configure systemd to do its job but somehow no one seems to have solved it. How do you register multiple sockets for a single service? I have tried without success variations of

httpd.socket:

[Unit] Description=Apache httpd Server Socket

[Socket] ListenStream=80 NoDelay=true DeferAcceptSec=30

[Socket] ListenStream=8080 NoDelay=true DeferAcceptSec=30

[Install] WantedBy=sockets.target