Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

With rpmfusion repo since fedora25 came out I have been having to use "--no-gpg-check" switch with whichever flavor of rpm/yum/dnf pays attention to that particular option. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward.

With rpmfusion repo since fedora25 came out I have been having to use "--no-gpg-check" switch with whichever flavor of rpm/yum/dnf pays attention to that particular option. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward.afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

With rpmfusion repo since fedora25 came out I have been having to use "--no-gpg-check" switch with whichever flavor of rpm/yum/dnf pays attention to that particular option. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

Pretty sure this isn't a "fedora" problem, it is an "rpmfusion" problem.

With rpmfusion repo since fedora25 came out I have been having to use "--no-gpg-check" "--nogpgcheck" switch with whichever flavor of rpm/yum/dnf pays attention to that particular option. yum. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

Pretty sure this isn't a "fedora" problem, it is an "rpmfusion" problem.

With rpmfusion repo since fedora25 came out I have been having to use "--nogpgcheck" switch with yum. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

Pretty sure this isn't a "fedora" problem, it is an "rpmfusion" problem.

EDIT: I've just been able to run "dnf update" with the newest rpmfusion repos installed (using the rpmfusion rpms to add them). I first had to make sure the rpms weren't "installed":

rpm -e rpmfusion-free-updates
rpm -e rpmfusion-nonfree-updates

and then I had to "get rid" of the old gpg keys from the fedora24 versions in /etc/pki/rpm-gpg, ala:

sudo mv /etc/pki/rpm-gpg/*rpmfusion* /someotherplace

and then

sudo rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm sudo rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

With rpmfusion repo since fedora25 came out I have been having to use "--nogpgcheck" switch with yum. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

Pretty sure this isn't a "fedora" problem, it is an "rpmfusion" problem.

EDIT: I've just been able to run "dnf update" with the newest rpmfusion repos installed (using the rpmfusion rpms to add them). I first had to make sure the rpms weren't "installed":

sudo rpm -e rpmfusion-free-updates
sudo rpm -e rpmfusion-nonfree-updates

and then I had to "get rid" of the old gpg keys from the fedora24 versions in /etc/pki/rpm-gpg, ala:

sudo mv /etc/pki/rpm-gpg/*rpmfusion* /someotherplace

and then

sudo rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm 
sudo rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

%fedora).noarch.rpm