English
Ask Your Question
0

cannot switch to tty console when nauveau driver is used

asked 2017-01-11 17:26:47 +0000

Aleksandar Kostadinov gravatar image

updated 2017-01-13 17:20:18 +0000

Hello, using laptop with intel and nvidia card [1]. In the past nouveau did not detect my card and I had no issues switching between graphics and text consoles. Now [2] it seems to be detecting the card and trugin to switch "Ctrl+Alt+F##" results it having current display just hang. If I go back to graphics console by "Alt+F1" then I can continue normal work.

This makes me thing that there is some confusion when trying to switch to text mode and I see last graphical screen. And I actually switch to console but can't see anything happening until I switch back to graphics.

update: after playing with some options, it turns out that on first boot there is no issue with switching to tty. After a few suspend/resume cycles and possibly related to docking/undocking the issue starts to manifest - as described above.

[1] GM108M/GeForce 940MX [2] kernel-core-4.8.15-200.fc24.x86_64

edit retag flag offensive close merge delete

Comments

try nomodeset in the linux command line, just in front of the word quiet in the grub editor on bootup, and if that helps, modify the /etc/default/grub to make it permanent.

steveebey73742 ( 2017-01-11 23:19:23 +0000 )edit

@steveebey73742, reading some docs it looks like this would disable nouveau ( https://nouveau.freedesktop.org/wiki/... ). If the kernel module nouveau is loaded according to lsmod command, but there are no kernel messages about nouveau at all, then most likely Nouveau KMS is disabled. This prevents the driver to work at all. Aren't there better ways to disable nouveau than disabling KMS?

Aleksandar Kostadinov ( 2017-01-12 09:04:17 +0000 )edit

sure, you could use dracut to --omit-drivers nouveau and rebuild initramfs. nomodeset simply turns off the attempt by nouveau to figure out the graphics mode of the nvidia display, and insted it forces a generic 1024x768 resolution.

steveebey73742 ( 2017-01-12 14:10:15 +0000 )edit

see my update, probably not unsupported card but something related to powerstates. A thread suggests my xf86-video-nouveau 1.12 is a little old ( https://bbs.archlinux.org/viewtopic.p... ). I need to spend osme time upgrading to fedora 25 and check if that will get fixed.

Aleksandar Kostadinov ( 2017-01-13 17:32:34 +0000 )edit

If you want to upgrade, I'd suggest Fedora 26. You'll get newer drivers and it might behave much better (or worse ;)) on your system!

hedayat ( 2017-08-21 20:30:37 +0000 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-09-24 16:50:02 +0000

Aleksandar Kostadinov gravatar image

I assume nouveau is not there yet. Although it works surprisingly well with some tests, once I figured out how to completely disable the stupid GPU, most artifacts I've hit are gone.

I needed to put rd.driver.blacklist=nouveau in kernel command line options in /etc/default/grub. Also added blacklist nouveau to /etc/modprobe.d/00local.conf.

I had even more issues with XFCE 4.12.x. Now I feel like I have a stable and responsive system again. Nouveau should really rovide an easier way to get out of the way when user doesn't need GPU.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2017-01-11 17:26:47 +0000

Seen: 150 times

Last updated: Sep 24