Ask Your Question
0

Wifi not working fedora 25 [closed]

asked 2017-01-15 15:10:16 -0600

kirkman gravatar image

Just installed fedora 25 and I cannot see an option to connect to wifi. I am currently plugged into ethernet well trying to solve this problem.

The following command displays lspci | grep -i wireless

08:00.0 Network controller: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter (rev 03)

iwconfig displays

lo no wireless extensions.

eno1 no wireless extensions.

I have no idea what to do from here, everything I have tried so far has not worked.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by florian
close date 2017-02-12 19:34:59.931066

Comments

Most likely Fedora doesn't come with a driver for that device. You may need to install the driver manually using the Linux driver from the vendor website: https://www.broadcom.com

porjo gravatar imageporjo ( 2017-01-15 16:35:42 -0600 )edit

This question has been asked answered many many times on this forum. Please use the search function to find quick answers and avoid duplicate questions. Check out this one: https://ask.fedoraproject.org/en/ques...

florian gravatar imageflorian ( 2017-02-12 19:34:38 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-17 14:18:54 -0600

jdieter gravatar image

Follow the instructions at the RPM Fusion Configuration page to enable both the free and nonfree repositories.

Then, from a terminal, type in the following:

sudo dnf install broadcom-wl

This will install Broadcom's proprietary driver which supports the BCM4352 chipset

edit flag offensive delete link more

Comments

Thank you, I just done that. Unfortunately it says I already have this installed. Still no option to connect to any wireless network.

The exact message is: Last metadata expiration check: 0:01:03 ago on Thu Jan 19 22:49:43 2017. Package broadcom-wl-6.30.223.271-1.fc24.noarch is already installed, skipping. Dependencies resolved. Nothing to do. Complete!

kirkman gravatar imagekirkman ( 2017-01-19 16:55:43 -0600 )edit

Sorry, just saw this. In a terminal, can you please try typing modprobe wl? If it gives you any errors, please check the journal (

journalctl -r
will show the latest messages) and share them in a comment.

jdieter gravatar imagejdieter ( 2017-01-22 10:30:22 -0600 )edit

Also, while, I'm thinking about it, if you haven't already, you'll need to disable Secure Boot, otherwise RPM Fusion's kernel modules won't load.

jdieter gravatar imagejdieter ( 2017-01-22 11:24:01 -0600 )edit

Hi I'm also having this problem, I installed the drivers & did a modprobe & everything looked like it went right but its just not working! I've followed a lot of these guides: 1st guide sudo dnf install -y https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-25.noarch.rpm https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-25.noarch.rpm sudo dnf install -y broadcom-wl kernel-devel sudo akmods --force --kerneluname -r--akmod wl sudo modprobe -a wl says it exists, says its all installed.. 2nd guide: sudo yum install "kernel-devel-uname-r == $(uname -r)"

karl6994 gravatar imagekarl6994 ( 2017-02-21 20:34:54 -0600 )edit

I have no idea how to make the text box on these forums at all, my apologies. the uname -r has those tick things ` on both sides of it

karl6994 gravatar imagekarl6994 ( 2017-02-21 20:37:54 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2017-01-15 15:10:16 -0600

Seen: 12,081 times

Last updated: Jan 17 '17