Broadcom BCM43142 monitor mode support

asked 2017-01-19 09:36:15 +0000

updated 2017-01-20 12:13:35 +0000

Hi, I was trying to set up my device into monitor mode but whenever I try to I get this message:

$ sudo iwconfig wlp3s0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlp3s0 ; Operation not supported.

Output of lspci | grep BCM:

 03:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)

Output of grep 'rfkill\|wireless':

$ lsmod | grep 'rfkill\|wireless'
rfkill                 24576  7 bluetooth,hp_wmi,cfg80211
hp_wireless            16384  0

Output of rpm -qa | grep Network:

$ rpm -qa | grep Network
NetworkManager-config-connectivity-fedora-1.4.2-2.fc25.x86_64
NetworkManager-wwan-1.4.2-2.fc25.x86_64
NetworkManager-1.4.2-2.fc25.x86_64
NetworkManager-openconnect-1.2.4-3.fc25.x86_64
NetworkManager-team-1.4.2-2.fc25.x86_64
NetworkManager-vpnc-1.2.4-1.fc25.x86_64
NetworkManager-vpnc-gnome-1.2.4-1.fc25.x86_64
NetworkManager-bluetooth-1.4.2-2.fc25.x86_64
NetworkManager-libnm-1.4.2-2.fc25.x86_64
NetworkManager-wifi-1.4.2-2.fc25.x86_64
NetworkManager-pptp-1.2.4-1.fc25.x86_64
NetworkManager-glib-1.4.2-2.fc25.x86_64
NetworkManager-openvpn-gnome-1.2.6-1.fc25.x86_64
NetworkManager-adsl-1.4.2-2.fc25.x86_64
NetworkManager-openvpn-1.2.6-1.fc25.x86_64
NetworkManager-pptp-gnome-1.2.4-1.fc25.x86_64

kernel:

 $  uname -a 
 Linux localhost.localdomain
 4.8.15-300.fc25.x86_64 #1 SMP Thu Dec 15 23:10:23 UTC 2016 x86_64 x86_64
 x86_64 GNU/Linux

Starting airmon-ng output:

[erabti@localhost ~]$ sudo airmon-ng check kill

Killing these processes:

  PID Name
 1277 wpa_supplicant

[erabti@localhost ~]$ sudo airmon-ng start wlp3s0


PHY Interface   Driver      Chipset

phy0    wlp3s0      wl      Broadcom Limited BCM43142 802.11b/g/n (rev 01)

        (experimental wl monitor mode vif enabled for [phy0]wlp3s0 on [phy0]prism0)

Airplay-ng -9 output:

[erabti@localhost ~]$ sudo  aireplay-ng -a 94:A7:B7:4F:22:BE -e S.M.0 -9 prism0 --ignore-negative-one
10:36:40  Waiting for beacon frame (BSSID: 94:A7:B7:4F:22:BE) on channel -1
For the given BSSID "94:A7:B7:4F:22:BE", there is an ESSID mismatch!
Found ESSID "S.M.O" vs. specified ESSID "S.M.0"
Using the given one, double check it to be sure its correct!
10:36:40  Trying broadcast probe requests...
10:36:42  No Answer...
10:36:42  Found 1 AP 

10:36:42  Trying directed probe requests...
10:36:42  94:A7:B7:4F:22:BE - channel: 1 - 'S.M.0'
10:36:48   0/30:   0%

I'm totally new to GNU/Linux and Fedora in general. At first when I installed fresh copy of Fedora 25 the Wi-Fi wasn't work so I installed and followed this article. I installed rpmfusion free and non-free and installed akmod-wl.

edit retag flag offensive close merge delete