Ask Your Question
1

Is there any way to disable notifications in GNOME Shell?

asked 2017-01-19 09:17:29 -0500

oddestNeeds gravatar image

updated 2017-01-19 09:54:14 -0500

mattdm gravatar image

They are annoying and cause the mouse to stick while the notifications pop. That's on a dual core 3 Gig box.

Furthermore, I need my applications to communicate. Not discommunicate. If one application has found the information i want, I want the other application to pop out over a clutter of windows. Not disappear after I fail to click the notification banner in the given time, which varies based on loading.

The gnome extension "steal my focus" restored the utility of the desktop to me, not fedora, but has been consistently disabled, for no reason I can think of.

If a user has a bady behaved application, it's their responsibility to live with it or find one that works correctly, is my opinion.

It is not the role of the operating to disable the utility of a user's program selection.

the "Steal-my-focus" extension provided complete user customization. Why is not available for Fedora 25?

Any clues as to how to disable the notification banners & permit focus-stealing would be desperately appreciated.

As it is now, I spend my time hunting windows, and, not being productive.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2017-01-19 09:53:16 -0500

mattdm gravatar image

You could install the Do Not Disturb GNOME Shell Extension. This disables immediate receipt of notifications and keeps a count of them instead.

Your issue with focus-stealing seems like a separate thing; that extension is from here and it looks like the author simply needs to update the extension for GNOME 3.22 compatibility; probably filing an issue with that project's github page is the best bet.

edit flag offensive delete link more
0

answered 2017-01-20 09:20:49 -0500

oddestNeeds gravatar image

Thanks for the info Matt.

I tried the extension & it didn't install on Fed 25

It appears to stop notifications branded as notifications and has the same basic functionality as suggested by

Mao Tao. The Settings->Notifications does not stop the notification banner from intercepting my TCP requests to pop a window. It's my program, if I use the keyboard to pop the window, surely god will permit me to do the same thing via tcp.

edit flag offensive delete link more
0

answered 2017-01-19 11:46:52 -0500

MaoTao gravatar image

Have you tried the options given at:

Settings -> Notifications (first row, second item) ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-19 09:17:29 -0500

Seen: 2,660 times

Last updated: Jan 20 '17