Ask Your Question
2

Touchpad libinput to xorg configuration not working

asked 2017-01-22 04:45:03 -0500

plegermi gravatar image

Hi guys, i'm trying to get my ETPS/2 Elantech Touchpad working on F25. Using gnome with wayland by default.

The basic functions are working fine, but a few things don't: - tab-to-click - pinch in/out (and rotation) - horizontal scrolling

I managed to fix the tab-to-click by using the gnome-settings, but it only affects the user currently logged in. At the login screen its not working.

Using libinput-debug-events i can see that all operations are recognised correctly. E.G. event7 POINTER_AXIS +11.25s vert 0.23* horiz 3.53* (finger) >> vertical scroll

event7   GESTURE_PINCH_BEGIN  +19.03s   2 
event7   GESTURE_PINCH_UPDATE +19.03s   2  2.55/ 0.00 ( 7.62/ 0.00 unaccelerated)  1.06 @  0.46 
event7   GESTURE_PINCH_END +19.39s  2

This was the debug when pinching in / rotating.

Here is the output of libinput-list-devices:

Device:           ETPS/2 Elantech Touchpad
Kernel:           /dev/input/event7
Group:            9
Seat:             seat0, default
Size:             99.90x66.22mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Running xinput lists only these devices:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer:13                       id=6    [slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:13              id=7    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ xwayland-keyboard:13                      id=8    [slave  keyboard (3)]

I tried to configure the touchpad by creating a xorg.conf.d/ snippet, but the config makes no difference. Has anyone an advice for me to get the touchpad running with tab-to-click in login screen and pinch/gesture mode activated when logged in?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-01-25 16:33:26 -0500

whot gravatar image

You have an "xwayland-pointer" device - this means that you're running under Wayland. Specifically: you're running a gnome session with mutter as your compositor. Whenever you run an X application, you're connecting to XWayland, a bridge between X applications and the Wayland compositor. XWayland doesn't have drivers (because it uses the compositor to render and get input over the wayland protocol) and thus doesn't honor the xorg.conf. It's similar to XNest, if you're familiar with that. Those devices are artificial devices that bridge between the real devices in wayland and the devices an X server needs to have.

https://wayland.freedesktop.org/xserv... has a diagram to explain it.

Solution: go back to gdm and select GNOME on X.org as option.

edit flag offensive delete link more

Comments

I have the same touchpad and the same problem, this solution work for you?

brunachox gravatar imagebrunachox ( 2017-08-06 21:20:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-22 04:45:03 -0500

Seen: 1,306 times

Last updated: Jan 25 '17