Ask Your Question
0

Getting dependencies error while installing a .rpm

asked 2012-11-06 00:45:23 -0500

juned gravatar image

updated 2013-06-03 07:10:06 -0500

I just created the rpm file from source. but while installing that rpm package i am getting this Error

[root@localhost ~]# rpm -ivh /root/x86_64/asterisk-1.8.12.2-1.fc15.x86_64.rpm 
error: Failed dependencies:
        libc.so.6(GLIBC_2.14)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libc.so.6(GLIBC_2.7)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libc.so.6(GLIBC_2.8)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libcap.so.2()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libcrypto.so.10()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libedit.so.0()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libgsm.so.1()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libpopt.so.0(LIBPOPT_0)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libresample.so.1()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libspeexdsp.so.1()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libsrtp.so.0()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libssl.so.10()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libtinfo.so.5()(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libxml2.so.2(LIBXML2_2.4.30)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        libxml2.so.2(LIBXML2_2.6.0)(64bit) is needed by asterisk-1.8.12.2-1.fc15.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by asterisk-1.8.12.2-1.fc15.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by asterisk-1.8.12.2-1.fc15.x86_64

I have also try to resolve the dependencies by using this:

[root@localhost ~]# yum-builddep asterisk-1.8.12.2-1.fc15.src.rpm 
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.hns.net.in
 * extras: mirrors.hns.net.in
 * updates: mirrors.hns.net.in
Checking for new repos for mirrors
autoconf-2.59-12.noarch
automake-1.9.6-2.3.el5.noarch
openssl-devel-0.9.8e-22.el5_8.4.x86_64
newt-devel-0.52.2-15.el5.x86_64
ncurses-devel-5.5-24.20060715.x86_64
libcap-devel-1.10-26.x86_64
gtk2-devel-2.10.4-21.el5_7.7.x86_64
Error: No Package found for libsrtp-devel

How to resolve these dependencies, please give me some suggestion to solve this issues.
Thanks & Regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-06 00:59:13 -0500

Remi gravatar image

You are trying to build a fedora 15 RPM on EL-5. So of course you encounter missing dependencies. You need to provide them.

And I don't know if EL-5 is on the target of this "Ask Fedora" site.

edit flag offensive delete link more

Comments

@juned: No, RPM doesn't work that way. It links against system packages that are versioned to the OS you are running. If you were running EL6, there are asterisk packages in EPEL, but there don't appear to be packages for EL5.

wquine gravatar imagewquine ( 2013-06-03 17:36:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-06 00:45:23 -0500

Seen: 2,991 times

Last updated: Jun 03 '13