Fedora 25 Bluetooth keyboard hangs bluetooth stack

asked 2017-01-25 11:09:24 +0000

Gurenko_Alex gravatar image

Hello everyone

Background: I've got a very disappointing issue with my bluetooth keyboard. I've recently purchased Microsoft Surface Ergonomic Keyboard ( http://www.microsoft.com/en-us/surfac... ) and it worked just fine for a week with my Lenovo T460p. After a week I had to re-install OS due to other issues with a laptop and now I cannot use this keyboard.

Problem: As soon as I pair the device it works for a few seconds and then whole bluetooth becomes unresponsive. I can reset it with hciconfig hci0 reset but then same thing happen on every connect. I can type for a few seconds and then it hangs. If I have a bluetooth headphones connected and playing music everything hangs right away without giving me even few seconds to type.

journalctl does not show anything

journalctl -k only shows following: kernel: input: 04:xx:xx:xx:xx:xx as /devices/virtual/input/input27

This keyboard still works fine with same Fedora 25 KDE and same updates installed on my other X1 Carbon.

Any ideas what can it be and how to troubleshoot it?

edit retag flag offensive close merge delete

Comments

I've found a kernel bug in linux-firmware that seems to relate to the problem: https://bugzilla.kernel.org/show_bug... . but downgrading linux-firmware package does not fix the issue. I'm still not sure, what exactly changed since it USED TO WORK with same set of packages.

Gurenko_Alex ( 2017-01-29 13:33:21 +0000 )edit