English
Ask Your Question
2

The final battle between GNOME 3 and hibernating

asked 2012-07-29 18:14:28 +0000

updated 2012-07-29 18:16:01 +0000

Hi everyone! I know this is an age-old issue, but I tried all default solutions, and even more complicated ones, and nothing seems to work.

The problem obviously is about not having any hibernate option in the user menu in the top right corner. I already installed both gnome-tweak-tool and the alternate status gnome shell extension, but that just lead to a separate power off button, without having to hold ALT to transform suspend option into it.

The upower -d command gives me can suspend: yes (in fact suspension alone perfectly works) and can hibernate: no, and giving the sole pm-hibernate command on terminal does not work at all, everything happens too fast to read any eventual error message, but it just immediately returns to my session, after having attempted hibernation, with backlight fully on.

I'm running Fedora 17 on a laptop (ASUS U36SG), and when I used my Desktop PC the alternate status worked fine, but I'm running other distros in here and they all hibernate without any problem.

Anyone has any idea? Ask me for further informations or console commands' output if necessary.

Thanks, have a nice day!

edit retag flag offensive close merge delete

Comments

I'm not sure what's causing this. I can hibernate just fine using pm-hibernate on my Fedora 17 with Gnome 3. It shouldn't be a Gnome issue IMO.

FranciscoD_ ( 2012-07-31 10:17:13 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2012-08-10 18:20:33 +0000

updated 2012-08-10 18:26:08 +0000

Well, kinda solved it... hope at least it will be useful for the ones who might make the dumb mistake which I did... the problem is Fedora did not automatically mount the swap partition on startup, so that it had nowhere to save the RAM to hibernate. An easy noobish way to check this is open GParted, and see if the swap partition has or hasn't the key icon of a mounted partition.

The reason was the incorrect UUID (Universally Unique IDentifier) stored in fstab for that partition, probably because some other distro changed it while formatting the swap to use it itself. To get the correct UUID I used sudo blkid, and then copied the swap partition's UUID replacing the one which were in fstab (sudo gedit /etc/fstab)

Thanks to everyone, sorry for the loss of time and have a good day!

P.S. After correcting that I also greatly reduced the boot time, as previously it stayed stuck a couple of minutes after started recreate volatile files and directories voice, probably because the next one was something about swapon I think. Anyway, solved, killed two birds with one stone.

edit flag offensive delete link more
0

answered 2012-08-11 04:52:06 +0000

updated 2012-08-11 05:29:42 +0000

mmm this is very strange, try it:

/bin/sh -c 'echo disk > /sys/power/state'

If it work then, you need to create a script

gedit HisDudeness.sh

Copy & paste

#!/bin/bash

/bin/sh -c 'echo disk > /sys/power/state'

give execution permissions

chmod +x /path/to/directory/HisDudeness.sh
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2012-07-29 18:14:28 +0000

Seen: 5,192 times

Last updated: Aug 11 '12