English
Ask Your Question
1

Fedora 17 will NOT install on virtualbox

asked 2012-07-08 21:19:48 +0000

fedoraNoob gravatar image

updated 2012-07-08 21:22:26 +0000

I have had this problem for a week now. I cannot for the life of me get Fedora to install on Virtualbox... it ALWAYS hangs right after the start screen where it says to Install Fedora 17. Instead of the usual input of date, time, etc. I am greeted with a black screen. This has happened with every ISO image (Live-CD, 32bit and 64-bit DVD). I have also burned all three images to DVD and still receive the same results.

I have no idea what I am doing wrong, since all I have done is create a 50 GB hard drive, gave it a name, enabled 3D acceleration and gave it 128MB video memory. I have tried to upload a screenshot of my configuration, but I also get the error "file is not defined"

I will give you the configuration of my host computer and from Virtualbox. Please help, I really want to learn linux and expand my computing skills.

Host Machine:

Intel Core i7 870 Processor
ATI RADEON 5770 Video Card
16 GB Memory
3 TB Total Hard Disk Space
Windows Server 2008 R2

Virtual Machine

Fedora (Virtualbox)
Base Memory 2 GB
Video Memory 128 MB
Hard Disk 50 GB Dynamic Expanding
Internet: MAC Bridged Miniport

Source Disks used:

Fedora 17 Live CD 86-64
Fedora 17 i386 DVD
Fedora 17 x86_64 DVD
edit retag flag offensive close delete

Comments

What systems settings do you set? The extended features especially can have an effect. The first time I tried to install F16 on VB I enabled EFI and the installation kept crashing on me.

BCD3 ( 2012-07-09 15:30:24 +0000 )edit

9 Answers

Sort by ยป oldest newest most voted
1

answered 2012-07-10 14:44:35 +0000

Akshay gravatar image

updated 2012-07-10 14:53:17 +0000

Make sure you have selected 64 bit fedora in VBOX

its working on my side

Host Machine :
AMD A8-4500M APU with Readon HD Graphics
ATI Readon HD 7640G + 7670M Dual Graphics
Memory : 8 GB
Storage : 1 TB

VBOX

image description

edit flag offensive delete publish link more

Comments

i am using both 32 and 64 bit

Akshay ( 2012-07-10 15:01:29 +0000 )edit

I see only 768MB of ram which is a tad low. Are you sure you're using the latest version of Virtualbox?

R. Daneel Oliwav ( 2012-07-15 02:52:10 +0000 )edit

768 mb is minimum RAM required by fedora so if you select fedora there by default VBOX will set it to 768 Mb if you wanna change during setup you can set it to whatever you want

Akshay ( 2012-07-15 03:41:22 +0000 )edit
0

answered 2012-09-28 12:55:26 +0000

Franck gravatar image

Ihave experienced that Fedora-17-x86_64-Live-Desktop will not install, but if you go in Fedora home page>download>other download options (i think it'swritten so, because i read in italian) instead of Download now! and you download 32 or 64 bit (i've experienced 32 bit Fedora-17-i686-Live-Desktop.iso) All works well. I don't know why the other doesn't work, but i've solved in this way.

edit flag offensive delete publish link more
0

answered 2012-09-28 12:48:24 +0000

Franck gravatar image

updated 2012-09-28 12:56:35 +0000

I have experienced that Fedora-17-x86_64-Live-Desktop doesn't works, Fedora-17-i686-Live-Desktop.iso works well.

edit flag offensive delete publish link more

Comments

@Franck both works well

Akshay ( 2012-09-28 17:27:40 +0000 )edit
0

answered 2012-07-10 11:16:21 +0000

Me too facing the same issue. I have recently downloaded Fedora Core 17 64 Bit DVD. I tried installing the same using virtualbox. I am getting the welcome screen but after pressing ENTER key for fresh install, black screen appears and installation does not proceed further....

Many Thanks, Nikhil Bhalwankar

edit flag offensive delete publish link more
0

answered 2012-08-05 20:20:38 +0000

fedoraNoob gravatar image

Thanks everyone for the responses. I figured out the problem. It was the "end user" :)

The problem is caused due to the fact that there were two virtual hosts running simultaneously. In this case it was Hyper-V and Virtualbox. The problems is that BIOS will only allow the first virtual hosting service to use the Virtualization technology. Unfortunately in my case, that would be Hyper-V, since once it is installed is automatically started with Windows. I uninstalled the Hyper-V roll, and Viola! Fedora 17 installed without a hitch! Make sure that you only have one Virtual host installed -- it will save you a lot of headaches in the future! :)

Again thanks for the responses. I will archive them for future reference.

edit flag offensive delete publish link more
0

answered 2012-07-26 18:36:35 +0000

it was doing the same thing to be when i was using the 64 bit iso, but when i switched to 32 bit it worked fine. my vbox didnt have an option for 64 bit. maybe i have 32bit vbox?

edit flag offensive delete publish link more

Comments

if you type fedora 64 instead of just fedora in OS name then vbox will set it to 64 bit

Akshay ( 2012-07-27 02:41:43 +0000 )edit
0

answered 2013-07-06 06:21:21 +0000

I do not have two VM's running and I ensure to click on install on harddrive. Yet every time I reboot the installation starts all over again. Should I take a snap shot before rebooting? I am trying to install Fedora 18. I had the same issue with 19 so it has to be something I am doing. Any suggestions would be useful. Thank s

edit flag offensive delete publish link more
0

answered 2013-05-28 03:08:11 +0000

I had a similar issue. I discovered I had the option for enhancing virtual machines (name varies Intel/AMD) turned off. I turned it on and everything worked like a charm. VB basically insists you have this turned on if you run 64-bit.

edit flag offensive delete publish link more
0

answered 2013-04-28 17:22:55 +0000

rajesh gravatar image

i am using Fedora-17-i686-Live-KDE (64bit)to run on virtualBox on my dell N 5521 laptop . when i try to install thing goes well but when it say Cong.... and ask to reboot VM Virtual box stop responding and it have to be closes . result in abort on VB. any solution ??

edit flag offensive delete publish link more

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2012-07-08 21:19:48 +0000

Seen: 22,728 times

Last updated: Jul 06 '13