dmesg error 110: SD Freezing OS: New

asked 2017-02-21 00:05:59 +0000

Beta_OmegaAdinf gravatar image

updated 2017-02-21 22:35:12 +0000

So I've been working on getting this solved all day and posted to several forums for answers with no luck.

As of today, after upgrading the system and enabling RPM-Fusion, I began to have problems with my SD card and adaptor. When the card is put into the adaptor and then inserted into the laptop everything freezes. GUI control? Gone. Keyboard and Terminal? Gone. I literally have to wait there until the card is slowly mounted, read, and control is passed back to the user. ( It takes anywhere from 1-2 minutes on my laptop to regain control. It used to take 0 minutes and 0 seconds, and I also would get a nice "Success, your device was mounted" ( Not verbatim ) message at the top of the screen, that is gone now. )

Originally I thought it was due to some dirty bits being present on the SD so I used fsck on it and removed 11 dirty bits, but it is still freezing everytime the card is inserted. New error messages are:

mmc0: card never left busy state
mmc0: error -110 whilst initializing SD card
mmc0: error -110 whilst initializing MMC card

Just as a side-note, the card is still accessible. After control is passed back to me I can go to the point it was mounted and manipulate files within and add files to the card. It's only when initially plugging it in that I run into the problem, the problem being that something is happening when trying to access an SD, which is taking excessive amounts of time and completely ripping control of the computer away from the user during that time. What is going on? Is this a bug in the kernel? If so I can downgrade, not a problem. If not, what is happening? Why am I suddenly having problems with my SD card that I didn't have before?

EDIT: The keyboard is still functional as well as the mouse during the course of the freeze. The screen isn't refreshing/redrawing the screen when a change is made while attempting to mount.

Relevant Mount Output:

/dev/mmcblk0p1      errors=remount-ro

It is mounted and it will continue to mount successfully.

Relevant df Output:

 Filesystem           1k-Blocks    Used     Available    Use%       Mounted on
/dev/mmcblk0p1      15629312    384    15628928     1%      /run/media/*User*/UNTITLED

Relevant dmesg -wH Output:

mmc0: new high speed SDHC card at address b386
mmcblk0: mmc0:b368               14.9 GiB (ro)
mmcblk0:  p1

Notice the lack of errors in dmesg regarding the SD card now? Still freezes though and I, at times, get a -5 error rather than the -110 that I was consistently getting yesterday.

Journalctl | grep rror Output:

 Feb 21 13:40:02 Host.Root gnome-shell[1519]: JS ERROR: TypeError:  is null
 Feb 21 13:39:12 Host.Root tracker-miner-f[1750]: Could not set mount point in database
 'urn:nepomuk:datasource:65ec95d45a83e66b39ac48ef527e2f12',
 GDBus.Error:org.freedesktop.Tracker1.SparqlError.Internal: UNIQUE constraint failed:
 nie:DataObject.nie:url (strerror of errno (not necessarily related): Resource temporarily unavailable)
edit retag flag offensive close merge delete