Ask Your Question
0

Boot hangs if acpi_osi=Linux enabled in grub

asked 2012-09-12 20:24:40 -0600

kvothe gravatar image

I am trying to get fedora 17 to work on my gateway nv78 laptop, and it is being an uphill struggle. At the moment, I can successfully boot into fedora if I leave the nomodeset option in my boot command list. However, if I remove it, my screen goes blank. If I add in acpiosi=Linux, I can see the screen, but the boot hangs. If I remove quiet from the command list, the last message displayed is "ADDRCONF(NETDEVCHANGE): wlan0: link becomes ready" Nothing happens after this.

What do I need to do to get things working? The laptop has integrated intel 4500mhd graphics, and the wifi card is the intel wifilink 5100agn

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-14 02:02:27 -0600

ZenDark gravatar image

The nomodeset bit reminds me of this bug (FC18, FC17, FC16).

https://bugzilla.redhat.com/show_bug.cgi?id=848305

Try removing it and the rhgb, and not adding acpi_osi=Linux (that can break a lot of things)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-12 20:24:40 -0600

Seen: 1,292 times

Last updated: Sep 14 '12