English
Ask Your Question
0

HTTPD will not start

asked 2013-02-09 16:49:51 +0000

hubbertus gravatar image

updated 2013-02-09 17:38:20 +0000

hhlp gravatar image

Can someone tell me why I am having problem with HTTPD after installation of joomla....

[root@fedora18 ~]# systemctl status httpd
httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
      Active: failed (Result: exit-code) since Sat 2013-02-09 10:42:17 CST; 1min 37s ago
     Process: 1158 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=1/FAILURE)
     Process: 1156 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)

Feb 09 10:42:17 fedora18 systemd[1]: Starting The Apache HTTP Server...
Feb 09 10:42:17 fedora18 httpd[1156]: httpd: Syntax error on line 352 of /etc/httpd/conf/httpd.conf: Syntax error on line 149 of /etc/httpd/conf.d/system-config-httpd.conf: /etc/httpd/conf.d/system-config-httpd.conf:155: <Directory> was not closed.\n/etc/httpd/conf.d/system-config-httpd.conf:153: <Directory> was not closed...: <Directory> was not closed.
Feb 09 10:42:17 fedora18 systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Feb 09 10:42:17 fedora18 httpd[1158]: httpd: Syntax error on line 352 of /etc/httpd/conf/httpd.conf: Syntax error on line 149 of /etc/httpd/conf.d/system-config-httpd.conf: /etc/httpd/conf.d/system-config-httpd.conf:155: <Directory> was not closed.\n/etc/httpd/conf.d/system-config-httpd.conf:153: <Directory> was not closed...: <Directory> was not closed.
Feb 09 10:42:17 fedora18 systemd[1]: httpd.service: control process exited, code=exited status=1
Feb 09 10:42:17 fedora18 systemd[1]: Failed to start The Apache HTTP Server.
Feb 09 10:42:17 fedora18 systemd[1]: Unit httpd.service entered failed state
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-02-09 18:37:54 +0000

Message seems clear. Your httpd configuration files are corrupt.

Have you use system-config-http ? I have always consider this tool with a lot of precaution, and recommend to not use it.

So, switch back to default httpd.conf (can't help more without seeing the files)

Note : fedora 18 provides Apache 2.4, the new major version, which have a lot of change in its configuration file.

edit flag offensive delete link more

Comments

"reinstall" never solves configuration issue. You must "uninstall", clean the configuration file, and then "install" again.

Remi ( 2013-02-10 06:43:23 +0000 )edit
0

answered 2013-04-15 21:03:18 +0000

lyxbit gravatar image

updated 2013-04-15 21:05:14 +0000

Maybe a clean reinstall isn't needed. If your Fedora 18 was upgraded from version 17, you must import your Apache HTTPD Server 2.2 custom settings (/etc/httpd/conf/httpd.conf.rpmsave") to Apache HTTPD Server 2.4 configuration file which template is "/etc/httpd/conf/httpd.conf.rpmnew", then create a new httpd.conf. The Apache HTTPD Server 2.4 example configuration file can also be obtained from the sources supplied on Apache HTTPD website. Your custom configuration files under '/etc/httpd/conf/config.d' must also be updated. Some parameter adaptations must be done, look the Apache documentation reference: "Upgrading to 2.4 from 2.2"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2013-02-09 16:49:51 +0000

Seen: 4,909 times

Last updated: Apr 15 '13