Ask Your Question
0

glxchoosevisual failed

asked 2017-03-05 03:12:27 -0500

juliusaugustus gravatar image

I am Fedora 25 KDE

I am using a Nvidia GTX 1070

Installed Nvidia drivers using RPM Fusion

Whenever I start steam I get this error

glxchoosevisual failed

What should I do?

edit retag flag offensive close merge delete

Comments

Steam is a 32 bit application, have you installed all nvidia i686 bits?

fcomida gravatar imagefcomida ( 2017-03-05 11:09:02 -0500 )edit

I would remove rpmfusion, get latest driver Linux x64 at www.nvidia.com , install with dkms and 32bit compatibility when the installer runs, and dkms will update the driver with kernel changes automatically.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-03-05 11:54:37 -0500 )edit

@steveebey73742 rpmfusion has nvidia akmod, dkms and 32bit libraries, why are you suggesting to install a driver that's difficult to manage?

fcomida gravatar imagefcomida ( 2017-03-05 15:33:29 -0500 )edit

@fcomida define difficult. every kernel update since installation dkms has automatically updated my driver, with no intervention from me. Only issue, as with any package, is when dependencies get updated. even then all that I do is reinstall the same driver, and it rebuilds with the new dependencies. Sounds fairly simple to me.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-03-06 09:23:23 -0500 )edit

@steveebey73742 dnf will take care of everything since nvidia drivers are in rpmfusion with all the dependencies (you see, dnf takes care of package dependencies). I don't see any reason for installing a piece of software outside the packaging system if that software has already been packaged for you.

fcomida gravatar imagefcomida ( 2017-03-06 17:08:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-07 03:06:22 -0500

As comments have suggested, it's important to install the i686 libraries for the driver you are using.

For instance; I use the nvidia-driver.x86_64 package, so to avoid this error with Steam, you'll need to install "nvidia-driver-libs.i686". You may need to find the appropriate library package for your exact driver (e.g. If you use 'xorg-x11-drv-nvidia', you'll need 'xorg-x11-drv-nvidia-libs.i686')

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-03-05 03:12:27 -0500

Seen: 1,482 times

Last updated: Mar 05 '17